[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Bruce Ingalls
Subject: Re: w32 ssh trouble
Date: Thu, 15 May 2003 14:52:44 GMT
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Thanks to Kai's help on XEmacs notation, I can noew try with XEmacs,
and discover that it works almost the same as Emacs (in this regard).

I tried plink v0.53b (should be latest binary release), and I was
able to get the prompt for the password, when I run it inside M-x shell.
However, it does not recognize my password, even though I know that I
am entering it correctly.
I was able to get the following to work inside M-x shell. I don't think
it matters, whether I use Cygwin or Cmd.exe for the child shell:

plink -ssh -batch -pw mypassword address@hidden

This is less secure, as users can spy on `ps`, but that's not an issue on my single user machine. I'm not sure if this is a security problem on Windows in general, as I don't know of a way to look at command line args to running processes, even if I were to connect my machine in a public area, leave it logged in, and walk away, or allow Administrators to snoop (via e.g. RDP), for that matter.

As far as Emacs versions:
It looks that I was using native Emacs. This is the only binary widely
distributed. I could not find a version of Emacs, which runs on the w32
desktop, yet supports Cygwin.

I did discover that running the Cygwin Emacs package inside the Cygwin
shell does work.
There is still an annoying bug, where Cygwin Emacs does not recognize C-x C-c to quit Emacs, and I must use the F10/M-' menu.
This is a bug in the port of Emacs to Cygwin.

The version of XEmacs I work with, runs on the w32 desktop, but is
compiled with Cygwin.

Finally, I tried plink under both Cygwin & cmd shells, and it recognized my password the first time. Thus, M-x shell in Windows is making some kind of change to my password.

Jason Rumney wrote:
Bruce Ingalls <address@hidden> writes:

I am trying to get TRAMP to work under w32.
Note that Linux works fine for me.

I tried executing M-x shell, then ssh.
This fails, with the error
Pseudo-terminal will not be allocated because stdin is not a terminal.

Why am I getting this error, and what can I do about it?

You are getting the error because the version of ssh you are using
expects a certain method of faking Unix pttys (I could take a wild
guess here and say that you're using a Cygwin port of ssh).

You could try using an alternative ssh client. plink (the putty
command-line client) seems like it could work if you can get comint
to recognize the passphrase prompt.

I do not have these shell problems with w32 XEmacs.

Cygwin version?

1.3.22 - Everything is latest binary release

reply via email to

[Prev in Thread] Current Thread [Next in Thread]