[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Jason Rumney
Subject: Re: w32 ssh trouble
Date: 15 May 2003 21:07:15 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3

Bruce Ingalls <address@hidden> writes:

> I tried plink v0.53b (should be latest binary release), and I was
> able to get the prompt for the password, when I run it inside M-x shell.
> However, it does not recognize my password, even though I know that I
> am entering it correctly.

Right. I got the same when I tried, that's why I mentioned making
comint recognize that plink is prompting for a password/passphrase so
it treats it differently. Perhaps that would not solve the problem
though. Plink works for me with certificate authentication and
pageant running (so it doesn't prompt for anything).

> As far as Emacs versions:
> It looks that I was using native Emacs. This is the only binary widely
> distributed. I could not find a version of Emacs, which runs on the w32
> desktop, yet supports Cygwin.

Right, the Cygwin version only supports tty and X. I know of no plans
to make it support the native Windows GUI.

> Finally, I tried plink under both Cygwin & cmd shells, and it
> recognized my password the first time. Thus, M-x shell in Windows is
> making some kind of change to my password.

Maybe (line end characters perhaps). Or maybe the way that plink
reads its password is not compatible with the indirection of running
a shell within Emacs.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]