[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Jason Rumney
Subject: Re: w32 ssh trouble
Date: 15 May 2003 08:06:31 +0100
User-agent: Gnus/5.09 (Gnus v5.9.0) Emacs/21.3

Bruce Ingalls <address@hidden> writes:

> I am trying to get TRAMP to work under w32.
> Note that Linux works fine for me.
> I tried executing M-x shell, then ssh.
> This fails, with the error
> Pseudo-terminal will not be allocated because stdin is not a terminal.
> Why am I getting this error, and what can I do about it?

You are getting the error because the version of ssh you are using
expects a certain method of faking Unix pttys (I could take a wild
guess here and say that you're using a Cygwin port of ssh).

You could try using an alternative ssh client. plink (the putty
command-line client) seems like it could work if you can get comint
to recognize the passphrase prompt.

> I also tried running ftp under the shell, but Emacs hangs, no error.

Cygwin ftp? Same problem perhaps.

> I do not have these shell problems with w32 XEmacs.

Cygwin version? You would probably get the ptty emulation that Cygwin
expects if you used the Cygwin port of Emacs as well.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]