[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Kai Großjohann
Subject: Re: w32 ssh trouble
Date: Sat, 17 May 2003 21:46:10 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Bruce Ingalls <address@hidden> writes:

> Kai Großjohann wrote:
>> Bruce Ingalls <address@hidden> writes:
>>>I tried plink v0.53b (should be latest binary release), and I was
>>>able to get the prompt for the password, when I run it inside M-x shell.
>>>However, it does not recognize my password, even though I know that I
>>>am entering it correctly.
>> What happens when you use M-: (process-send-string nil "your-pw\n")
>> RET to send the password?  What happens when you use \r instead of
>> \n?  What happens when you use \r\n instead of \n?
> Well, It's a bit hard to do this, in the middle of a password prompt.
> It tries to read in M-: (whatever control char that generates) as my
> password.

Hm.  Well, you can remove comint-watch-for-password-prompt from
comint-output-filter-functions.  That ought to remove the minibuffer
prompt and thus you can do M-: normally.

> I did try to do a C-g (a second time, after I got a "Non echoed text"
> prompt) and I noticed this phenomenon:
> The shell seems to chop off the last 2 characters of my input.

Huh?  That's weird.

I could put stuff in Tramp that adds junk to passwords.  (Are we
talking about Tramp?)  Surely I would do this if it makes users
happy.  But it makes me feel REALLY REALLY uneasy.  *shudder*
This line is not blank.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]