[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Kai Großjohann
Subject: Re: w32 ssh trouble
Date: Sun, 18 May 2003 17:02:33 +0200
User-agent: Gnus/5.1003 (Gnus v5.10.3) Emacs/21.3.50 (gnu/linux)

Bruce Ingalls <address@hidden> writes:

> Kai Großjohann wrote:
>> Bruce Ingalls <address@hidden> writes:
>>>I tried appending any 2 chars to the end, and this worked.
>> Amazing.
>>>Now that I can get plink working under M-x shell, I tried adding
>>>garbage to the end of my password in Tramp, but that did not work.
>>>Unfortunately, this is not a good indicator, as Plink only works for
>>>me via protocol 1, and I'll have to fool with Tramp settings for this.
>> What's the command line you use to tell plink to use protocol 1?
>> I'll add an entry plink1 to tramp-methods for you.
> -1 just like ssh.

Great.  I've now added the entry.  New version in CVS.

So if I understand you correctly, you just have to append two random
chars to your password, and then it will work, right?

Whee.  I wonder what's going to happen.  It's really weird.

>>>I understand your unease. The other solution is to pass in passwords,
>>>using Plink's -pw command line option.
>> Whee.  That doesn't seem better.
> I forgot to mention, that you don't need to append garbage, when
> passing the password on the command line.


Hm.  Does it work to set tramp-password-end-of-line to "xx\n"?  It's
a really really really dirty trick.  But who knows...

Alas, Tramp is not flexible enough to allow different values of
tramp-password-end-of-line for different methods.
This line is not blank.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]