[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w32 ssh trouble

From: Bruce Ingalls
Subject: Re: w32 ssh trouble
Date: Sat, 17 May 2003 12:45:05 GMT
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

Kai Großjohann wrote:
Bruce Ingalls <address@hidden> writes:

I tried plink v0.53b (should be latest binary release), and I was
able to get the prompt for the password, when I run it inside M-x shell.
However, it does not recognize my password, even though I know that I
am entering it correctly.

What happens when you use M-: (process-send-string nil "your-pw\n")
RET to send the password?  What happens when you use \r instead of
\n?  What happens when you use \r\n instead of \n?

Well, It's a bit hard to do this, in the middle of a password prompt.
It tries to read in M-: (whatever control char that generates) as my
I did try to do a C-g (a second time, after I got a "Non echoed text" prompt) and I noticed this phenomenon:
The shell seems to chop off the last 2 characters of my input.

Thus, "your-pw\r\n" would work best, as the \r and \n will get chopped out. In other words, this seems to work, but not for the reasons you expected.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]