[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling 2.19.83 needs guile-config < 1.9.0

From: Bric
Subject: Re: compiling 2.19.83 needs guile-config < 1.9.0
Date: Fri, 17 Jan 2020 16:48:41 -0500 (EST)

On January 16, 2020 at 4:47 PM Thomas Morley < address@hidden> wrote:

Am Do., 16. Jan. 2020 um 21:29 Uhr schrieb Bric < address@hidden>:
I think this was discussed before, but i'm not sure how to downgrade guile on Ubuntu 18.04.2 LTS
I tried building guile-1.8.0, guile-1.8.4, guile-1.8.5, but the build fails for all three.
lilypond ./configure error:
ERROR: Please install required programs: guile-config < 1.9.0 (installed: 2.2.3) (guile-devel, guile-dev or libguile-dev package) libguile (libguile-dev, guile-devel or guile-dev package). GUILE-with-rational-bugfix
You likely need to point configure to guile and guile-config

../configure GUILE_CONFIG=/path/to/guile-config GUILE=/path/to/guile

i don't follow the above.   You would point to /path/to/guile-config and /path/to/guile if you have the right version installed. Lilypond is complaining that my installed version is too new.

A (rare) need to downgrade a dependency, correct? 

Or -- correct me if i'm wrong -- as an alternative to downgrading, I could build an old, compatible version from source, to an isolated directory, and satisfy the lilypond dependency that way?

I was asking about the latter:  the older versions of guile are not compiling.

Has anyone  run into this?  and solved it?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]