[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling 2.19.83 needs guile-config < 1.9.0

From: Michael Käppler
Subject: Re: compiling 2.19.83 needs guile-config < 1.9.0
Date: Fri, 17 Jan 2020 08:47:42 +0100
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.3.1

Am 16.01.2020 um 22:47 schrieb Thomas Morley:
Am Do., 16. Jan. 2020 um 21:29 Uhr schrieb Bric <address@hidden>:
I think this was discussed before, but i'm not sure how to downgrade guile on 
Ubuntu 18.04.2 LTS

I tried building guile-1.8.0, guile-1.8.4, guile-1.8.5, but the build fails for 
all three.

lilypond ./configure error:

ERROR: Please install required programs: guile-config < 1.9.0 (installed: 
2.2.3) (guile-devel, guile-dev or libguile-dev package) libguile (libguile-dev, 
guile-devel or guile-dev package). GUILE-with-rational-bugfix
You likely need to point configure to guile and guile-config

../configure GUILE_CONFIG=/path/to/guile-config GUILE=/path/to/guile

Sorry, did accidentally forget to reply also to the list.
What I was unsure from the your post, Bric, is what "... the build fails
for all three" means.
a) You could not build guile, neither 1.8.0, 1.8.4, nor 1.8.5
b) You did successfully build three different versions of guile, but
haven't had success with none of them in compiling lilypond.

In any case it would be good to know
a) Which version of LP are you trying to compile? From current master?
b) If building guile is the problem, how does the build actually fail?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]