[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling 2.19.83 needs guile-config < 1.9.0

From: Bric
Subject: Re: compiling 2.19.83 needs guile-config < 1.9.0
Date: Sat, 18 Jan 2020 22:00:52 -0500 (EST)

On January 18, 2020 at 6:05 PM David Kastrup < address@hidden> wrote:

Michael Käppler < address@hidden> writes:

Am 18.01.2020 um 09:36 schrieb David Kastrup:
Bric < address@hidden> writes:
>>> I was asking about the latter: the older versions of guile are not compiling.
>>> Has anyone run into this? and solved it?
>> Take the tip of the branch_release-1-8 branch in the Guile repository.
>> Thien-Thi Nguyen has kept that compilable even though no official
>> release is.
This is interesting. A couple of hours ago I had the discussion with
whether there is a reason for compiling guile in LilyDev postinstall
based on branch_release-1-8 rather
than just taking guile-1.8.8.tar.gz from
Are the fixes on top of the guile-1.8.8 release really important for us?
We probably still need to configure using --disable-error-on-warning ,
and without those changes, building will fail at least when trying to
build the documentation with a newer Texinfo version.

./configure option "--disable-error-on-warning"  made guile-1.8.8 compile (yay) The "errors" were warnings raised to errors apparently (?)

After that, lilypond-2.19.83 ./configure was happy about the guile version, and completed configure.

But then lilypond errors out on:

GNUmakefile:295: recipe for target 'out/internals.texi' failed"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]