[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling 2.19.83 needs guile-config < 1.9.0

From: David Kastrup
Subject: Re: compiling 2.19.83 needs guile-config < 1.9.0
Date: Sun, 19 Jan 2020 00:05:01 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.50 (gnu/linux)

Michael Käppler <address@hidden> writes:

> Am 18.01.2020 um 09:36 schrieb David Kastrup:
>> Bric <address@hidden> writes:
>>> I was asking about the latter:  the older versions of guile are not 
>>> compiling.
>>> Has anyone  run into this?  and solved it?
>> Take the tip of the branch_release-1-8 branch in the Guile repository.
>> Thien-Thi Nguyen has kept that compilable even though no official
>> release is.
> This is interesting. A couple of hours ago I had the discussion with
> Federico
> whether there is a reason for compiling guile in LilyDev postinstall
> based on branch_release-1-8 rather
> than just taking guile-1.8.8.tar.gz from
> Are the fixes on top of the guile-1.8.8 release really important for us?

We probably still need to configure using --disable-error-on-warning ,
and without those changes, building will fail at least when trying to
build the documentation with a newer Texinfo version.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]