[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Ubuntu 18.04.3 build from source testing

From: Gary E. Miller
Subject: Re: Ubuntu 18.04.3 build from source testing
Date: Mon, 16 Dec 2019 19:56:03 -0800

Yo Steve!

On Mon, 16 Dec 2019 21:33:10 -0600 (CST)
Steve Bourland <address@hidden> wrote:

> Hopefully the log attaches correctly, if not let me know and I will
> sort something out (sorry, I'm old school email and use alpine as my
> client).

The attachment worked.  Alpine was great, while it lasted.  Too many new
things it does not support.

The raw.log looks fine to me.  Did anything in there look wrong to you?

Since it looks like the recently added regression I'll just keep it
in case you mention something.

> >    find /usr -xdev -name -exec ls -l {} \;  
> find /usr -xdev -name -exec ls -l {} \;
> -rw-rw-r-- 1 root staff 12456 Dec 16 16:01 
> /usr/local/lib/python2.7/dist-packages/gps/

Odd.  I would have expected it in site-packages...

> - ntp and gpsd aren't talking to each other, expected them to at
> least talk at the "gps" level if not PPS.

Which is why I keep asking for the output of:
        1) full build log
        2) ntpshmmon

> - xpgs is not a happy camper, happy to have this system in a bad way
> as long as needed to sort things out.

Which is very odd.

> When running scons it did
> indicate it wasn't going to install xgps, haven't looked back at the
> logs to see why.

Well, if scons says no, then it will not work.  Those tests are there for
good reasons.  Not good to proceed after you get an error.

> Everything else looks super good to me at this point.  I'm at a loss
> where to go WRT ntp and xgps....nevermind....need to run gpsd as root
> to get the shared memory, my bad, sorry.

No, you do not need root.  It just works differently without root.
ntpshmmon would have shown how/why.

>  Now have the NMEA
> sentences, but no PPS yet (tried the stty command, oddly required
> 9600 baud, can't explain that, 4800 lead to loss of the "NMEA" lines).

Just let the autobaud work.  9600 is the Garmin 18x default.  Changing
it require gpsctl to work, which in your case it ahs not.

> ppstest /dev/pps0
> trying PPS source "/dev/pps0"
> found PPS source "/dev/pps0"
> ok, found 1 source(s), now start fetching data...
> time_pps_fetch() error -1 (Connection timed out)
> time_pps_fetch() error -1 (Connection timed out)

If ppstest fails, then gpsd can not read /dev/pps0 either.

That means you have a connection problem or a driver problem.  Well
before gpsd starts.  Check your wiring, your voltages and your
kernel modules.

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
    "If you can't measure it, you can't improve it." - Lord Kelvin

Attachment: pgpWeTay70OXl.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]