help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Upgrading elpa packages results in Lisp nesting exceeds max-lisp-eva


From: Michael Heerdegen
Subject: Re: Upgrading elpa packages results in Lisp nesting exceeds max-lisp-eval-depth...
Date: Sun, 06 Oct 2019 19:40:07 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Stefan Monnier <address@hidden> writes:

> Indeed it's a bug in async.el.
> Does the patch below help?

I can't really test anymore, since all packages are updated now...but
evaluating (async-bytecomp-get-allowed-pkgs) gives me

Debugger entered--Lisp error: (wrong-type-argument listp async)
  cdr(async)
  (setq pkgs (cdr pkgs))
  (prog1 pkgs (setq pkgs (cdr pkgs)))
  (car-safe (prog1 pkgs (setq pkgs (cdr pkgs))))
  (let ((pkg (car-safe (prog1 pkgs (setq pkgs (cdr pkgs)))))) (if (memq pkg 
seen) nil (let ((pkg-desc (car (cdr (or ... ...))))) (if pkg-desc (progn (setq 
seen (cons pkg seen)) (setq pkgs (nconc pkgs (progn ... ...))))))))
  (while pkgs (let ((pkg (car-safe (prog1 pkgs (setq pkgs (cdr pkgs)))))) (if 
(memq pkg seen) nil (let ((pkg-desc (car (cdr ...)))) (if pkg-desc (progn (setq 
seen (cons pkg seen)) (setq pkgs (nconc pkgs ...))))))))
  (let ((seen 'nil)) (while pkgs (let ((pkg (car-safe (prog1 pkgs (setq pkgs 
...))))) (if (memq pkg seen) nil (let ((pkg-desc (car ...))) (if pkg-desc 
(progn (setq seen ...) (setq pkgs ...))))))) seen)
  async-bytecomp--get-package-deps(async)
  async-bytecomp-get-allowed-pkgs()

But it seems your patch did obsolete this function.  Could someone else
pls test?

Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]