help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Upgrading elpa packages results in Lisp nesting exceeds max-lisp-eva


From: Michael Heerdegen
Subject: Re: Upgrading elpa packages results in Lisp nesting exceeds max-lisp-eval-depth...
Date: Sun, 06 Oct 2019 17:24:59 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Joost Kremers <address@hidden> writes:

> I don't know about the OP, but I myself don't use helm and nothing
> helm-related seems to be installed:
>
> ~ $ v .elpa/helm*
> .elpa/helm*: No such file or directory
>
> So why would I get the error, then?

Hmm, the error happens in `async-bytecomp-get-allowed-pkgs', it loops
over `async-bytecomp-allowed-packages' which includes helm (hardcoded in
async-bytecomp.el !).  When you upgrade packages
`async-bytecomp-get-allowed-pkgs' is called and that produces the issue
no matter which packages you have installed.

I guess setting async-bytecomp-allowed-packages to nil could be a
workaround but I don't want to try this now.

Michael.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]