[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gpsd-users] GPSD on Debian 10 (buster): allowing other hosts to acc

From: Florian Petry
Subject: Re: [gpsd-users] GPSD on Debian 10 (buster): allowing other hosts to access gpsd
Date: Thu, 19 Sep 2019 07:58:41 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.8.0


I have seen some issues with the gpsd socket configuration in systemd in the 

My working config here is:

Description=GPS (Global Positioning System) Daemon Sockets



Point is the commented IPv4 ListenStream option. Apparently IPv6 includes IPv4 there. This config is running for years now, currently on stretch.

I don't know if it helps on debian buster though...


Am 19.09.19 um 02:34 schrieb Charles Curley:
On Wed, 18 Sep 2019 12:07:00 -0700
"Gary E. Miller" <address@hidden> wrote:

Yo Charles!

On Wed, 18 Sep 2019 10:19:35 -0600
Charles Curley <address@hidden> wrote:

I have the Debian packaged gpsd (version 3.17-7 [Yes, I know:
ancient]) on Debian 10 (buster). It runs just fine and dandy,

Modulo a bunch of CVE...

I cannot access it from another computer. I have:

Uh, oh.

* Opened the firewall to allow packets in on gpsd's port, 2947.
   Firewall logging reports no hits on that port.

How did you verify that?  Did you try an nmap remotely?
        nmap -p 2947 xx.xx.xx.xx.

root@orca:~# nmap -p 2947 hawk
Starting Nmap 7.70 ( ) at 2019-09-18 17:57 MDT
Nmap scan report for hawk (
Host is up (0.0013s latency).
rDNS record for hawk.localdomain

2947/tcp closed gpsd
MAC Address: 30:5A:3A:81:83:79 (Asustek Computer)

Nmap done: 1 IP address (1 host up) scanned in 0.60 seconds

However, syslog on hawk does not show any packets hitting the firewall.

Did you look at netstat?
        netstat -apn | fgrep gpsd

root@hawk:/home/charles/versioned/gpsd# netstat -apn | fgrep gpsd
tcp        0      0         ESTABLISHED 
unix  2      [ ACC ]     STREAM     LISTENING     8442447  1/init               
unix  3      [ ]         STREAM     CONNECTED     8597869  16423/gpsd

* Copied gpsd.socket to /etc/systemd/system, and edited it to allow
   access from all interfaces:

Oh.  Then you realize you are not running gpsd, you are running
systemd which is hijacking port 2947...

gpsd is running. I have a receiver running, and I get reports on
multiple clients.

I'll bet you have a systemd problem.  Have you tried without

Good luck getting rid of systemd on Debian. Like kudzu or bureaucracy,
it takes over everything. I need to hornswaggle it into doing what I

* Edited /etc/default/gpsd to include the -G option:

And why not the "-n" option?

Possibly because I didn't see that it was relevant to the matter at
hand? I already have multiple clients on hawk getting data from gpsd.

In any case when I add the n option ("-Gn"), it shows up in ps's
output, but still no joy. Nmap still reports the port closed.

My clients find gpsd and the gps receiver on the local host, hawk.
On another computer, I cannot get to gpsd on hawk. Ping works.
Telnet reports that it is unable to connect. Xgps on the other
computer reports, "gpsd is not running."

What am I doing wrong?

You are running systemdumb.  Try the above 3 things and see what you

Gary E. Miller Rellim 109 NW Wilmington Ave., Suite E, Bend, OR 97703
        address@hidden  Tel:+1 541 382 8588

            Veritas liberabit vos. -- Quid est veritas?
     "If you can't measure it, you can't improve it." - Lord Kelvin

htw saar
Hochschule für Technik und Wirtschaft des Saarlandes
University of Applied Sciences

Fakultät für Ingenieurwissenschaften
School of Engineering

Florian Petry, M.Sc.
Forschungsgruppe Verkehrstelematik (FGVT)

Innovations Campus Saar
Altenkesseler Strasse 17/D2
66115 Saarbruecken

+49 681 5867-648

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]