discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ANN] HighlighterKit 0.1.2 and Gemas 0.3 - Gemas


From: Csanyi Pal
Subject: Re: [ANN] HighlighterKit 0.1.2 and Gemas 0.3 - Gemas
Date: Sun, 19 Feb 2012 16:55:03 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Sašo Kiselkov <address@hidden> writes:

> On 02/19/2012 02:08 PM, Csanyi Pal wrote:
>> Csanyi Pal <address@hidden> writes:
>> make messages=yes
>> 
>> <output>
>> This is gnustep-make 2.6.1. Type 'make print-gnustep-make-help' for
>> help. 
>> Making all for app Gemas...
>> gcc-4.6  -rdynamic       -shared-libgcc -fexceptions -fgnu-runtime -o
>> Gemas.app/./Gemas \ 
>>         ./obj/Gemas.obj/GemasController.m.o
>>         ./obj/Gemas.obj/GemasEditorView.m.o
>>         ./obj/Gemas.obj/GemasDocument.m.o ./obj/Gemas.obj/Gemas_main.m.o
>>         -L./HighlighterKit/HighlighterKit.framework
>>         -L/home/csanyipal/GNUstep/Library/Libraries -L/usr/local/lib
>>         -L/usr/lib   -lHighlighterKit          -lpthread -lobjc   -lm 
>> ./obj/Gemas.obj/GemasController.m.o: In function `-[GemasController
>> openPreferences:]': 
>> /home/csanyipal/Programozas/Obj_C_ben/GNUstep_letoltve_SVN-nel/gemas/GemasController.m:395:
>> undefined reference to `NSApp' 
>> ./obj/Gemas.obj/GemasController.m.o: In function `-[GemasController
>> openGoToLinePanel:]': 
>
> It seems like you have some serious issues with linking on your
> system. 

It is possible.

> Are you using a custom gnustep, or the one shipped in Debian?

It is a short story: first I has installed the one shipped in
Debian. Later I purge every debian gnsutep package. Then I use the 
http://dl.dropbox.com/u/8559454/GNUstep%20libobjc2%20on%20Ubuntu.sh
script by Ivan Vučica and had installed gnustep from svn sources. 
See this mail here:
http://article.gmane.org/gmane.comp.lib.gnustep.general/37316

Later I remove all (leastwise I think so) gnustep files previously
installed from sources and installed back debian gnustep packages
again. Well, that is my story. After that it seems that I have some
serious issues, like this one.

> These undefined symbols signal that your gnustep installation is very
> broken. 

How can I clean up everything now to get a clean debian gnustep?

-- 
Regards from Pal




reply via email to

[Prev in Thread] Current Thread [Next in Thread]