[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] Xerces library problem

From: tek
Subject: Re: [Mingw-cross-env-list] Xerces library problem
Date: Fri, 16 Jul 2010 16:16:32 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20100619 Icedove/3.0.5

On 07/16/2010 02:34 PM, Volker Grabsch wrote:
tek<address@hidden>  schrieb:
On 07/14/2010 03:21 PM, tek wrote:
Thank you Volker for pointing me in the right direction. As far as I
understood it, it does not seem to be a problem in the
mingw-cross-env's xerces.mk file, but deeper into the Xerces build.

Please confirm, so I can report it to the Xerces maintainers.
Here's how I fixed it:

$ cd /opt/mingw
$ sudo rm /bin/sh&&  sudo ln -s /bin/bash /bin/sh
$ rm usr/installed/xerces
$ make xerces
$ sudo rm /bin/sh&&  sudo ln -s /bin/dash /bin/sh
Sorry for not stopping you earlier on that. I'm afraid that you
were looking at the wrong direction.

Mainly my fault, I started to make things very wrong in the first place.

The problem is _not_ that Ubuntu uses Dash as /bin/sh, but that
the build process of Xerces involves some bashisms. So we should
fix Xerces, not Ubuntu.

And that's also what I suggested in my first attempt to fix it. But I was suggesting reporting it to Xerces maintainers instead of here, because I tried to redefine $(SHELL) in mingw-cross-env (which did not work as you say below).

Again, it's my fault. I was no clear enough overall.

Note that xerces.mk already contains an attempt to fix that:

     $(SHELL) ./configure \

where $(SHELL) is "bash". However, that approach apparently
doesn't work anymore. But it isn't the best approach anyway,
because ./configure scripts provide an explicit "CONFIG_SHELL=..."

     ./configure \
         ... \

We already do that in gdb.mk, and I just fixed gettext.mk and
xerces.mk to do it that way, too:

So please restore your /bin/sh to Dash

You can see that I did it already in the last line of my fix, because I don't like modifying my system like this (it usually hits you soon or later).

Thanks for the infos.

  and use our current
development version where xerces.mk is fixed:

Thanks for that! This is cleaner now.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]