[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Mingw-cross-env-list] Xerces library problem

From: tek
Subject: Re: [Mingw-cross-env-list] Xerces library problem
Date: Fri, 16 Jul 2010 01:40:52 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv: Gecko/20100619 Icedove/3.0.5

On 07/14/2010 03:21 PM, tek wrote:
$ ls -l usr/i686-pc-mingw32/lib/libxerces*

-rw-r--r-- 1 tek tek 35991560 Jul 14 14:53 usr/i686-pc-mingw32/lib/libxerces-c.a -rwxr-xr-x 1 tek tek 1256 Jul 14 14:53 usr/i686-pc-mingw32/lib/libxerces-c.la

I did not test it yet, but at least, it seems a lot more correct now.

Everything works now (attached patch).

I tested it with:


There was an "illegal instruction" deep inside the XMLPlatformUtils::Initialize() call. It appeared to be that my target CPU lacked support for SSE2 instruction set.

Thank you Volker for pointing me in the right direction. As far as I understood it, it does not seem to be a problem in the mingw-cross-env's xerces.mk file, but deeper into the Xerces build.

Please confirm, so I can report it to the Xerces maintainers.

Can someone confirm the /bin/sh issue by building Xerces with mingw-cross-env under an up-to-date Debian distribution?

Here's how I fixed it:

$ cd /opt/mingw
$ sudo rm /bin/sh && sudo ln -s /bin/bash /bin/sh
$ rm usr/installed/xerces
$ make xerces
$ sudo rm /bin/sh && sudo ln -s /bin/dash /bin/sh

And why:



Attachment: mingw-2.15-nosse2-1.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]