[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Checkout problem on cvs host

From: Todd Denniston
Subject: Re: Checkout problem on cvs host
Date: Wed, 26 Feb 2003 16:07:49 -0500

Craig Dickson wrote:
> > >
> > > When I run the following command on a client computer it works as
> expected:
> > >
> > > cvs -d :pserver:address@hidden:/usr/local/cvsroot checkout -d . test
> >
> >Running CVS as root is nuts.  Doing it using pserver doubly so.
> Its just a test system, so get over it.

still bad, because you do not get used to getting your directory permissions
and group file configured correctly.   working on getting over it. :)

> >
> > > However, when I run it on the box that is actually hosting the cvs
> pserver,
> > > I get this:
> > >
> > > cvs server: existing repository /usr/local/cvsroot does not match
> > > /usr/local/cvsroot/test
> > > cvs server: ignoring module test
> >
> > checkout really wants to create the directory.  The usual advice is to
> > run the command from one level higher in the tree with a real directory
> > name rather than ".".
> that doesn't explain the error message, since the operation works on a
> client. the question is, what is different when running on the actual host
> server that might cause this message?

it might help if you posted the pwd of the directory you were running your cvs
command from and the actual cvs line used on the server.
Kind of looks like you may be attempting to checkout a sandbox inside of the
repository, I believe cvs no longer likes that at all.

I'd crawl over an acre of 'Visual This++' and 'Integrated Development
That' to get to gcc, Emacs, and gdb.  Thank you.
        -- Vance Petree, Virginia Power

reply via email to

[Prev in Thread] Current Thread [Next in Thread]