[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 can not detect usb disk

From: Cui Lei
Subject: Re: Grub2 can not detect usb disk
Date: Tue, 28 Jun 2011 18:02:47 +0800
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110516 Thunderbird/3.1.10

Sorry , I don't know what the meaning of the "bisect" and how to do?
Could you tell me some message in detail ?
Thanks a lot.



On 28.06.2011 10:45, Rock Cui wrote:
I had tried to use the grub1.99rc2 as a payload of coreboot at the
beginning, but it can not boot my machine,
Could you try to bisect? Recent bzr worked fine in qemu+coreboot. Your
machine may present some special aspect and bisect is probably the
fastest way in your case.
so I changed to 1.98
As I said USB support in 1.98 wasn't good enough. Basically it worked
only in qemu.
, then booting succeed. I want to insmod the uhci.mod and usbms.mod to
support USB,
but they are not exit in my build folder. If I run "configure" with
"--with-platform=pc", they will be there, but
with "--with-platform=coreboot", I can not found them. I don't know
what should I do to get them for i386-coreboot, so I use the two
modules which were built with "--with-platform=pc" in my payload.elf.
USB modules weren't enabled in 1.98 on coreboot.
Surprising, they can be insmoded and run in the grub-shell , but
unfortunately, I got those logs, they can not
it's already surprising they didn't crash GRUB altogether.

_______________________________________________ Grub-devel mailing list address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]