[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 can not detect usb disk

From: Vladimir 'φ-coder/phcoder' Serbinenko
Subject: Re: Grub2 can not detect usb disk
Date: Tue, 28 Jun 2011 11:02:13 +0200
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110626 Iceowl/1.0b2 Icedove/3.1.11

On 28.06.2011 10:45, Rock Cui wrote:
> I had tried to use the grub1.99rc2 as a payload of coreboot at the
> beginning, but it can not boot my machine,
Could you try to bisect? Recent bzr worked fine in qemu+coreboot. Your
machine may present some special aspect and bisect is probably the
fastest way in your case.
> so I changed to 1.98
As I said USB support in 1.98 wasn't good enough. Basically it worked
only in qemu.
> , then booting succeed. I want to insmod the uhci.mod and usbms.mod to
> support USB,
> but they are not exit in my build folder. If I run "configure" with
> "--with-platform=pc", they will be there, but
> with "--with-platform=coreboot", I can not found them. I don't know
> what should I do to get them for i386-coreboot, so I use the two
> modules which were built with "--with-platform=pc" in my payload.elf.
USB modules weren't enabled in 1.98 on coreboot.
> Surprising, they can be insmoded and run in the grub-shell , but
> unfortunately, I got those logs, they can not
> work.
it's already surprising they didn't crash GRUB altogether.

Vladimir 'φ-coder/phcoder' Serbinenko

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]