[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Grub2 can not detect usb disk

From: Graeme Russ
Subject: Re: Grub2 can not detect usb disk
Date: Tue, 28 Jun 2011 21:27:49 +1000
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20110424 Thunderbird/3.1.10

On 28/06/11 21:08, Vladimir 'φ-coder/phcoder' Serbinenko wrote:
> On 28.06.2011 12:02, Cui Lei wrote:
>> Sorry , I don't know what the meaning of the "bisect" and how to do?
>> Could you tell me some message in detail ?
> You take a revision which doesn't work (1.99rc2 = r3229)  and a working
> one (1.98 = r2249). Then you try a revision in the middle, e.g. r2749.
> If it works the error is in the range 2749..3229, otherwise in
> 2249..2749, then you try a revision inside this range and in 10 steps
> you'll have the exact revision which causes your problem.

Does bazzar have the equivalent of git-bisect where you simply provide the
last known working version and the first known broken version and simply
answer a series of yes/no questions as the bisection is done in the
background automatically?



>> Thanks a lot.
>> BRs,
>> Rock.
>>> On 28.06.2011 10:45, Rock Cui wrote:
>>>> I had tried to use the grub1.99rc2 as a payload of coreboot at the
>>>> beginning, but it can not boot my machine,
>>> Could you try to bisect? Recent bzr worked fine in qemu+coreboot. Your
>>> machine may present some special aspect and bisect is probably the
>>> fastest way in your case.
>>>> so I changed to 1.98
>>> As I said USB support in 1.98 wasn't good enough. Basically it worked
>>> only in qemu.
>>>> , then booting succeed. I want to insmod the uhci.mod and usbms.mod to
>>>> support USB,
>>>> but they are not exit in my build folder. If I run "configure" with
>>>> "--with-platform=pc", they will be there, but
>>>> with "--with-platform=coreboot", I can not found them. I don't know
>>>> what should I do to get them for i386-coreboot, so I use the two
>>>> modules which were built with "--with-platform=pc" in my payload.elf.
>>> USB modules weren't enabled in 1.98 on coreboot.
>>>> Surprising, they can be insmoded and run in the grub-shell , but
>>>> unfortunately, I got those logs, they can not
>>>> work.
>>> it's already surprising they didn't crash GRUB altogether.
>>> _______________________________________________
>>> Grub-devel mailing list
>>> address@hidden
>> _______________________________________________
>> Grub-devel mailing list
>> address@hidden
> _______________________________________________
> Grub-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]