[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chicken-users Digest, Vol 225, Issue 9

From: Mark Fisher
Subject: Re: Chicken-users Digest, Vol 225, Issue 9
Date: Sat, 21 Aug 2021 17:26:28 +0100

Thanks George.

I tried strace on chicken-install, and it looks like it's loop crashing

--- Process 9068 created
--- Process 9068 loaded C:\Windows\System32\ntdll.dll at 00007ffdf6210000
--- Process 9068 loaded C:\Windows\System32\kernel32.dll at 00007ffdf5760000
--- Process 9068 loaded C:\Windows\System32\KernelBase.dll at 00007ffdf3f40000
--- Process 9068 thread 16552 created
--- Process 9068 loaded C:\Windows\System32\msvcrt.dll at 00007ffdf4270000
--- Process 9068 thread 4164 created
--- Process 9068 loaded C:\msys64\home\markj\dev\chicken-5.2.0\libchicken.dll at 00007ffdb30c0000
--- Process 9068 loaded C:\Windows\System32\advapi32.dll at 00007ffdf50b0000
--- Process 9068 loaded C:\Windows\System32\sechost.dll at 00007ffdf6130000
--- Process 9068 loaded C:\Windows\System32\rpcrt4.dll at 00007ffdf4b50000
--- Process 9068 thread 5128 created
--- Process 9068 loaded C:\Windows\System32\user32.dll at 00007ffdf4c80000
--- Process 9068 loaded C:\Windows\System32\win32u.dll at 00007ffdf3a00000
--- Process 9068 loaded C:\Windows\System32\gdi32.dll at 00007ffdf4310000
--- Process 9068 loaded C:\Windows\System32\gdi32full.dll at 00007ffdf3c20000
--- Process 9068 loaded C:\Windows\System32\msvcp_win.dll at 00007ffdf3a30000
--- Process 9068 loaded C:\Windows\System32\ucrtbase.dll at 00007ffdf3ad0000
--- Process 9068 loaded C:\Windows\System32\ws2_32.dll at 00007ffdf5560000
--- Process 9068 loaded C:\Windows\System32\imm32.dll at 00007ffdf5080000
--- Process 9068, exception c0000005 at 00007ffdf623faad
--- Process 9068, exception c0000005 at 00007ffdf623faad

The last 2 lines just repeat ad-infinitum.

I tried strace on a simple csi script which works fine without exceptions, so I think there's something wrong with the
compiled chicken-install application.

I was doing the compilation in a MINGW64 window, not a MSYS window, which is what I think you were referring to?
I can't compile it in a normal windows shell, as it would need MINGW64 paths setup for compiler etc.

I may try an earlier version of chicken and see if that works.

On Sat, 21 Aug 2021 at 17:00, <> wrote:
Send Chicken-users mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Chicken-users digest..."

Today's Topics:

   1. Installing Chicken 5.2.0 on Windows - chicken-install
      -update-db hanging (Mark Fisher)
   2. Re: Installing Chicken 5.2.0 on Windows - chicken-install
      -update-db hanging (George Oliver)


Message: 1
Date: Sat, 21 Aug 2021 12:14:51 +0100
From: Mark Fisher <>
Subject: Installing Chicken 5.2.0 on Windows - chicken-install
        -update-db hanging
Content-Type: text/plain; charset="utf-8"

Hi all,

I'm on a new PC with windows 10 and thought I'd try getting a chicken
environment up and running on MSYS2 MingGW-64.

I've installed a fresh copy of msys2 and mingw64 from the msys2 site, doing
the pacman updates on top.

I've then followed the guide at (except using
5.2.0 source instead) running under a MINGW64 terminal as advised.

The compilation works fine, but when I run the install phase, the
"chicken-install -update-db" just hangs:

    cp -r "C:/msys64/usr/local//lib/chicken/11"
    cp -r
    C:/msys64/usr/local//bin/chicken-install -update-db

I left it for an age, and checked if it was doing network activity, which
it doesn't seem to be.

opening another window, csi seems to work, but I can't install any eggs,
presumably because the chicken db is not being built.

    markj@teeny MINGW64 ~
    $ winpty csi -p '(+ 1 1)'

    markj@teeny MINGW64 ~
    $ chicken-install -s srfi-18

    Error: extension or version not found: "srfi-18"

Any advice on getting chicken-install working, or how to work out why it's

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>


Message: 2
Date: Sat, 21 Aug 2021 08:40:59 -0700
From: George Oliver <>
To: chicken chicken <>
Subject: Re: Installing Chicken 5.2.0 on Windows - chicken-install
        -update-db hanging
        <" target="_blank">>
Content-Type: text/plain; charset="UTF-8"

Hi Mark, I installed Chicken successfully on Windows not too long ago,
but unfortunately I've since switched my setup and I don't know what
your issue might be. However looking at the wiki instructions I do
remember that I didn't install Chicken 'in' msys, if that makes sense,
but from a 'normal' Windows command shell. Maybe there's some network
issue with msys -- could Windows be blocking it?

cheers, George


Subject: Digest Footer

Chicken-users mailing list


End of Chicken-users Digest, Vol 225, Issue 9

reply via email to

[Prev in Thread] Current Thread [Next in Thread]