[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chicken-users Digest, Vol 225, Issue 9

From: Mark Fisher
Subject: Re: Chicken-users Digest, Vol 225, Issue 9
Date: Sun, 22 Aug 2021 09:04:58 +0100

I've made some partial progress.
I installed mingw64-gcc and make into windows with chocolatey in a powershell instead of with MSYS2, which I think may be closer to what you have setup George?

I was then able to compile and install chicken. I couldn't work out how to set a PREFIX value that wouldn't stop it failing to compile, but not setting one at all and installing at least defaulted to installing in C:\chicken

Running from this version does run ok with csi, but running chicken-install gives:

- - - 8< - - -
> chicken-install -update-db
loading import libraries ...
generating database ...

Error: (open-output-file) cannot open file - No such file or directory: "/usr/local/lib/chicken/11\\modules.db"
- - -

I think it's using the "system separator" from the chocolatey version of mingw64, which is probably the windows system "\\", and mixing that with the fact I couldn't set a PREFIX value, and failing in windows as it doesn't understand forward slashes.
I tried running it under MSYS2/MingW64, but had exactly the same error, which I suspect is the other way around, this time the MSYS2 version fails to understand the "\\" at the end.
If I could set the system separator and compile under chocolatey, it might well work under MSYS2, like a cross compile.

I did notice that the gcc under chocolatey is 10.2, whereas with MSYS2 it's 10.3.

I tried downgrading the version of gcc in MSYS2, but pacman doesn't support downgrading easily, and although i was able to replace 10.3 with a previous 10.2 package and at least get gcc showing it was the correct version, it wouldn't actually compile chicken, and simply returned an error compiling the first file:

- - - 8< - - -
$ make PLATFORM=mingw-msys PREFIX=C:/msys64/usr/local/
gcc -fno-strict-aliasing -fwrapv -DHAVE_CHICKEN_CONFIG_H -DC_ENABLE_PTABLES -c -Os  -DC_BUILDING_LIBCHICKEN library.c -o library-static.o -I. -I./
make: *** [rules.make:121: library-static.o] Error 1
- - - 

I suspect this is because I couldn't find 10.2 versions of the other packages used to get a working environment to compile, and the versions are clashing somehow.

George, what version of gcc did you use to compile chicken? I suspect this may simply be a version issue, as my system is incredibly clean, so shouldn't be having these issues.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]