[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Uisp-dev] Example command lines?

From: Theodore A. Roth
Subject: Re: [Uisp-dev] Example command lines?
Date: Mon, 16 Dec 2002 16:01:38 -0800 (PST)

On Mon, 16 Dec 2002, Bob Paddock wrote:

:) > The -dpart option should not be case sensitive. You are missing the
:) > -dprog=stk500 option. This command should work for you:
:) >
:) >   $ uisp -dpart=stk500 -dserial=/dev/ttyS1 -dpart=AT90S8515 --rd_fuses
:) I think you mean -dprog=stk500 there.

Yes, cut and paste error on my part.

:) The first time I run, after cycling power, I get this:
:) /usr/local/bin/uisp -dprog=stk500 -dserial=/dev/ttyS1 -dpart=AT90S8515
:) --rd_fuses
:) Programmer is not responding.

That happens sometimes if you run uisp too soon after powering up the

:) Second time I run, no power cycle from the above, I get this:
:) /usr/local/bin/uisp -dprog=stk500 -dserial=/dev/ttyS1 -dpart=AT90S8515
:) --rd_fuses
:) Device is not responding correctly.

Try a different command, like --erase, instead of --rd-fuses. I don't
think the --rd-fuses works with the 8515 yet (there's a patch that might
help with that though).

Sadly, the current uisp source uses that error response in too many places
for it to be a very useful diagnostic. :-(

Ted Roth

reply via email to

[Prev in Thread] Current Thread [Next in Thread]