[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Uisp-dev] Example command lines?

From: Bob Paddock
Subject: Re: [Uisp-dev] Example command lines?
Date: Mon, 16 Dec 2002 17:33:11 -0500
User-agent: KMail/1.4.3

> What does your command line look like?

 uisp-20021201 # /usr/local/bin/uisp -dpart=AT90S8515 -dserial=/dev/ttyS1 
Invalid parameter: -dpart=AT90S8515

What is the right format for the 8515?  None the variations I tried worked.
This is what I get now, after recompiling and installing the Dec01 release.

> This assumes that the stk500 is connected to the default port of /dev/avr
> which looks like this on my system:
>   $ ls -l /dev/avr
>   lrwxrwxrwx    1 root     root       5 Jun 18 09:26 /dev/avr -> ttyS0
> You could also at the -dserial=/dev/ttyS0 to avoid using the default.
> The "command not found" is more likely coming from your shell saying that
> it can't find uisp. Is directory you installed uisp into in your PATH?
> Where did you install uisp?

I have uisp in /usr/local/avr/bin .  I just recompiled it and saw that it was 
'installed' in /usr/local/bin but I get the same results.

If I try to run 'dog' which does not exist I get 'no such file', where uisp 
gives 'no command specified'.

Also I don't have a /dev/avr.  What should have created that?

address@hidden AVR $ ls /dev/avr
ls: /dev/avr: No such file or directory

address@hidden AVR $ uisp
uisp: No command specified.
address@hidden AVR $ dog
bash: dog: command not found

      http://www.unusualresearch.com/ http://www.bpaddock.com/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]