[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Win 2019 to linux doesn't work

From: Harald Hannelius
Subject: Re: [rdiff-backup-users] Win 2019 to linux doesn't work
Date: Fri, 29 Mar 2019 13:57:06 +0200 (EET)
User-agent: Alpine 2.11 (LNX 23 2013-08-11)

On Fri, 29 Mar 2019, Dominic Raferd wrote:
On Fri, 29 Mar 2019 at 11:47, Harald Hannelius <address@hidden>
On Fri, 29 Mar 2019, Dominic Raferd wrote:
On Fri, 29 Mar 2019 at 11:01, Harald Hannelius <

If I run the command "ssh -C address@hidden rdiff-backup --server"
get a rdiff-backup in servermode on the linuxbox and typing characters
results in an python-error (which is expected).

I think you haven't specified the key correctly. Here is an example using
plink.exe (from
rdiff-backup.exe --remote-schema "plink.exe -P 22 -ssh -i
""C:\path\to\privatekey.ppk"" %s rdiff-backup --server"
C:/path/to/SourceData address@hidden::"/backup/repo1"

Nope, adding the -i option to ssh.exe didn't change anything. If I
command in the error-message and run it by itself it works. Same with or
without -i <key>.

Use plink, this is required when connecting from Windows.

I tried that too. I have the plink.exe command that starts a remote rdiff-backup on the linux-server and it works from the commandline on the windows-server.

However, rdiff-backup is unable to use plink.exe and fails with the same error.

Fri Mar 29 13:51:49 2019  Using rdiff-backup version 1.3.3
Fri Mar 29 13:51:49 2019  Executing  C:\Users\myself\Desktop\rdiff\plink.exe -P 
22 -ssh -i C:\users\myself\.ssh\putty-id.ppk  address@hidden 
/usr/bin/rdiff-backup --server
Fri Mar 29 13:51:49 2019  Client sending (0): ConnectionRequest: Globals.get 
with 1 arguments
Fri Mar 29 13:51:49 2019  Fatal Error:

Couldn't start up the remote connection by executing

     C:\Users\myself\Desktop\rdiff\plink.exe -P 22 -ssh -i 
C:\users\myself\.ssh\putty-id.ppk  address@hidden /usr/bin/rdiff-backup --server

Remember that, under the default settings, rdiff-backup must be
installed in the PATH on the remote system.  See the man page for more
information on this.  This message may also be displayed if the remote
version of rdiff-backup is quite different from the local version (1.3.3).


Harald Hannelius | harald.hannelius/a\arcada.fi | +358 50 594 1020

reply via email to

[Prev in Thread] Current Thread [Next in Thread]