[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [rdiff-backup-users] Win 2019 to linux doesn't work

From: Joe Steele
Subject: Re: [rdiff-backup-users] Win 2019 to linux doesn't work
Date: Fri, 29 Mar 2019 13:09:43 -0400
User-agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.5.3

I don't have experience with your setup. Nonetheless, here are some things to check:

Check the linux server logs. Are there any messages about ssh connection attempts from the Windows client?

Use tcpdump on linux (or maybe Wireshark on Windows) to see if a connection attempt is occurring.

Try adding the location of plink.exe to the Windows Path environment variable (but this shouldn't be necessary since it appears that you were invoking plink with the full path anyway.) To me, your error messages are consistent with rdiff-backup not being able to find and execute plink. Try intentionally misspelling plink when invoking rdiff-backup -- you likely will see the same error that you are currently getting.

Try a test by removing the passphrase from your private key. It may be that plink is unable to access the terminal in order to prompt for a passphrase.

On 3/29/2019 8:06 AM, Harald Hannelius wrote:

On Fri, 29 Mar 2019, Dominic Raferd wrote:
On Fri, 29 Mar 2019 at 11:57, Harald Hannelius <address@hidden>> wrote:

I tried that too. I have the plink.exe command that starts a remote
rdiff-backup on the linux-server and it works from the commandline on the

However, rdiff-backup is unable to use plink.exe and fails with the same

Googling the error shows that it has been seen with connection from Linux
clients, so I don't think it relates to Windows. Are you confident that you have the same versions of rdiff-backup on client and on server? Otherwise I
am out of ideas (I don't have Windows 2019 Server).

Yes, I have tried with both 1.2.8 and 1.3.3 as stated in the original e-mail.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]