[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[rdiff-backup-users] Win 2019 to linux doesn't work

From: Harald Hannelius
Subject: [rdiff-backup-users] Win 2019 to linux doesn't work
Date: Fri, 29 Mar 2019 13:00:18 +0200 (EET)
User-agent: Alpine 2.11 (LNX 23 2013-08-11)

Hi all,

I have a win 2019 server that I'd like to take backups from. I'm using the OpenSSH version included in MS RSAT and I have succesfully created SSH-keys and I can verify that running the ssh-command indeed starts a rdiff-backup in server-mode on the linux box.

C:\Users\myself\Desktop\rdiff\rdiff-backup.exe -v9 "foobar" 
Fri Mar 29 12:44:13 2019  Using rdiff-backup version 1.3.3
Fri Mar 29 12:44:13 2019  Executing ssh -C address@hidden rdiff-backup --server
Fri Mar 29 12:44:13 2019  Client sending (0): ConnectionRequest: Globals.get 
with 1 arguments
Fri Mar 29 12:44:13 2019  Fatal Error:

Couldn't start up the remote connection by executing

    ssh -C address@hidden rdiff-backup --server

Remember that, under the default settings, rdiff-backup must be
installed in the PATH on the remote system.  See the man page for more
information on this.  This message may also be displayed if the remote
version of rdiff-backup is quite different from the local version (1.3.3).

I have tried with both 1.2.8 and 1.3.3 on Windows to no avail. The linux-server is a Debian 8 box with rdiff-backup 1.2.8.

If I run the command "ssh -C address@hidden rdiff-backup --server" I get a rdiff-backup in servermode on the linuxbox and typing characters results in an python-error (which is expected).

Please advice on how to find out why this doesn't work.


Harald Hannelius | harald.hannelius/a\arcada.fi | +358 50 594 1020

reply via email to

[Prev in Thread] Current Thread [Next in Thread]