[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24

From: Eric Blake
Subject: Re: [Qemu-trivial] [Qemu-devel] [PATCH v1] configure: require glib-2.24
Date: Wed, 18 Apr 2018 08:34:13 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.7.0

On 04/18/2018 07:47 AM, Daniel P. Berrangé wrote:
> On Wed, Apr 18, 2018 at 02:38:37PM +0200, Olaf Hering wrote:
>> Since usage of g_realloc_n was introduced, glib-2.22 can not be used anymore.
>> Fixes commit 418026ca43 ("util: Introduce vfio helpers")
> Normally we expect ./include/glib-compat.h to be changed in this scenario
> to add compat for the missing symbol.

Or rewrite the offending addition of g_realloc_n to use something like
g_renew that IS available in 2.22 (this is not the first time the issue
has appeared; see commit 071d405, for example).

> IIRC, one of Peters desired build targets required 2.22, but I guess we
> missed this bug because that platform would not enable vfio functionality ?

Which platform?  CentOS 6 is at glib 2.28; we also require 2.30 for
building on mingw.  I'm not seeing an easy document that says which
distros we still actively support, and which culprit distro has the
oldest glib.

Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3266
Virtualization:  qemu.org | libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]