[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pan-users] Newbie compiling Pan v0.133 in Debian stable...

From: David Shochat
Subject: Re: [Pan-users] Newbie compiling Pan v0.133 in Debian stable...
Date: Sun, 1 Jul 2012 19:16:08 +0000 (UTC)
User-agent: Pan/0.139 (Sexual Chocolate; GIT bf56508 git://

On Sun, 01 Jul 2012 11:51:48 -0700, Ant wrote:
> The following packages have unmet dependencies:
>  libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going
> to be installed
>                  Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not
> going to be installed E: Broken packages
Well, I have to admit that (1) I've never seen an error message like that 
from apt-get and (2) if I did, I'd find it very frustrating, for the 
obvious reason that it is giving you no clue as to WHY, for example, 
libcairo2-dev "is not going to be installed". So I would probably follow 
that up with something like:
# apt-get install libcairo2-dev
just to see if it would lead to an actual explanation (or useful 
information). I find it very odd that Debian won't let you install 
libgtk2.0-dev since what is in it was obviously needed to build a very 
large number of the applications that came with the distribution.
Sorry I couldn't help you all the way to the make step. I guess my 
suggestion at this point would be to head over to and 
ask the obvious question:
"What does it take to install libgtk2.0-dev in stable"?
Hopefully someone there will be able to sort this out. I'm an Ubuntu 
user, but I've gotten lots of help from their forums so I figure it will 
be similar with Debian.
-- David

reply via email to

[Prev in Thread] Current Thread [Next in Thread]