[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Pan-users] Newbie compiling Pan v0.133 in Debian stable...

From: Ant
Subject: Re: [Pan-users] Newbie compiling Pan v0.133 in Debian stable...
Date: Sun, 1 Jul 2012 12:22:47 -0700
User-agent: Mutt/1.5.21 (2010-09-15)

> > The following packages have unmet dependencies:
> >  libgtk2.0-dev : Depends: libpango1.0-dev (>= 1.20) but it is not going
> > to be installed
> >                  Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not
> > going to be installed E: Broken packages
> > 
> Well, I have to admit that (1) I've never seen an error message like that 
> from apt-get and (2) if I did, I'd find it very frustrating, for the 
> obvious reason that it is giving you no clue as to WHY, for example, 
> libcairo2-dev "is not going to be installed". So I would probably follow 
> that up with something like:
> # apt-get install libcairo2-dev
> just to see if it would lead to an actual explanation (or useful 
> information). I find it very odd that Debian won't let you install 
> libgtk2.0-dev since what is in it was obviously needed to build a very 
> large number of the applications that came with the distribution.

# apt-get install libcairo2-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcairo2-dev : Depends: libcairo2 (= 1.8.10-6) but 1.10.2-7~bpo60+1 is 
to be installed
                 Depends: libpixman-1-dev (>= 0.12.0) but it is not 
going to be installed
E: Broken packages

Yeah, it's frustrating!

> Sorry I couldn't help you all the way to the make step. I guess my 
> suggestion at this point would be to head over to and 
> ask the obvious question:
> "What does it take to install libgtk2.0-dev in stable"?
> Hopefully someone there will be able to sort this out. I'm an Ubuntu 
> user, but I've gotten lots of help from their forums so I figure it will 
> be similar with Debian.

Thanks. Too bad I Ubuntu and Debian can't share the same exact packages. 
Quote of the Week: "When I was five years old, I saw an insect that had 
been eaten by ants and of which nothing remained except the shell. 
Through the holes in its anatomy one could see the sky. Every time I 
wish to attain purity I look at the sky through flesh." --Salvadore Dali
  /\___/\          Ant(Dude) @ (Personal Web Site)
 / /\ /\ \                 Ant's Quality Foraged Links:
| |o   o| |
   \ _ /              If crediting, then please kindly use Ant nickname
    ( )                                              and AQFL URL/link.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]