[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] flashing the c201

From: Marcel Maci
Subject: Re: [Libreboot] flashing the c201
Date: Thu, 18 Aug 2016 07:25:46 +0200

Hello Paulk and Rendov
I've never flashed a c201 but what surprises me a lot are these lines:

> The power, hold, and wp pins are all bridged and receiving power from
> {pin1,pin17} of the rpi, which is documented to provide 3.3v.

Does "bridged" mean that you put 3.3V to all three pins? Personally I only 
power the VCC pin and I'm using pin 1 (not 17) of the Raspberry Pi.
Hope this helps,

> El 17 ago 2016, a las 3:35, Rendov Norra <address@hidden> escribió:
> This is a continuation of an email I sent paulk, since he suggested I post
> here as well.
> I checked all of his suggestions except maybe if all the required pins are
> getting 3.3v. I'm not entirely clear on how to measure that. I get ~2v when
> measuring from the power source to the pin, and the ground connected.
> Measuring straight from the power to ground gives me 3.3v.
> The power, hold, and wp pins are all bridged and receiving power from
> {pin1,pin17} of the rpi, which is documented to provide 3.3v.
> I'm wiring it according to the following documents (pdf warning):
> ---------- Forwarded message ----------
> From: *Paul Kocialkowski* <address@hidden>
> Date: Monday, August 8, 2016
> Subject: On flashing the c201
> To: Rendov Norra <address@hidden>
> Hi,
>> Le dimanche 07 août 2016 à 19:45 -0400, Rendov Norra a écrit :
>> This is a bit of a longshot, but I'm pretty desperate.
>> I managed to make chromeos boot on the c201, and external device boot is
> off,
>> and the chromebook recovery images fail after ~5 minutes, so as far as I
> can
>> tell, using internal spi to flash is out of the question. I've resorted to
>> hardware flashing, but I can't get it (RasPi 3) talking to the chip. And
> it
>> boots into the firmware (and into recovery), so I know I haven't managed
> to
>> fry it.. At least I hope.
>> I've set the pins according to multiple sources, and re-checked them God
> knows
>> how many times. I've tried different configurations of powering the hold
> and
>> write protect pins. I've checked continuity between the RPi and the legs
> of
>> the chip too many times. The write protect screw is out. I've even tried
>> having it sit in the developer/recovery screens and use the power
> supplied by
>> the board. I've tried using upstream Flashrom, and I've tried using
> google's
>> Flashrom. No matter what I do, it returns "Unknown SPI chip".
>> I figured if anyone knew anything about this, it'd be you. Thanks for your
>> time.
> Please consider posting this to the Libreboot mailing list as well. This
> way,
> more people can help you and answer your inquiry while others can benefit
> from
> the question and its answers as well.
> Some notes and suggestion that may help you:
> * Make sure you've followed
>  and especially "Installing Libreboot externally, with a SPI flash
> programmer"
> * Check that the VDD, #WP and #HOLD of the chip are +3.3V during activity
> * Make sure that you're not using 1.8V logic, the chip seems to accept 3.3V
> only
> * Make sure you've disconnected the device's battery
> * Make sure you've disconnected any source of power
> * Maybe try with the battery connected, just in case
> Note that I'll be providing a recovery SPI flash image and rootfs with
> Debian
> that should allow recovering from these kinds of situations. Of course, your
> device is not irremediably bricked.
> Cheers,
> --
> Paul Kocialkowski, developer of low-level free software for embedded devices
> Website:
> Coding blog:
> Git repositories:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]