[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Libreboot] flashing the c201

From: Duncan Guthrie
Subject: Re: [Libreboot] flashing the c201
Date: Wed, 17 Aug 2016 21:36:43 +0100
User-agent: K-9 Mail for Android

Hi Rendov,
Here is some advice from my own experience flashing Libreboot.

If you have the pins correct as you say then this is almost certainly not the 
problem. Regardless, I would advise you to check them again just to be sure, 
though, as often silly mistakes can be made after working on something for a 
long time. 

When I externally flashed, I could never get a good connection with SPI speed 
of 512. This is due to wires not providing a enough good connection for 
stability at this speed. I used SPI speed of 128. It was quite slow but it 
worked. I also used the "BBB Screwdriver" tool, which is based on OpenWRT, on a 
Beaglebone black:; This tool is good for debugging and I 
can confirm that a ThinkPad X200 was successfully flashed using this tool. You 
will need to verify signatures of ROM images on the computer you control the 
BBB from over SSH, then send the file over SSH. The flashrom program is part of 

Hope this is of use,

On 17 August 2016 02:35:55 BST, Rendov Norra <address@hidden> wrote:
>This is a continuation of an email I sent paulk, since he suggested I
>here as well.
>I checked all of his suggestions except maybe if all the required pins
>getting 3.3v. I'm not entirely clear on how to measure that. I get ~2v
>measuring from the power source to the pin, and the ground connected.
>Measuring straight from the power to ground gives me 3.3v.
>The power, hold, and wp pins are all bridged and receiving power from
>{pin1,pin17} of the rpi, which is documented to provide 3.3v.
>I'm wiring it according to the following documents (pdf warning):
>---------- Forwarded message ----------
>From: *Paul Kocialkowski* <address@hidden>
>Date: Monday, August 8, 2016
>Subject: On flashing the c201
>To: Rendov Norra <address@hidden>
>Le dimanche 07 août 2016 à 19:45 -0400, Rendov Norra a écrit :
>> This is a bit of a longshot, but I'm pretty desperate.
>> I managed to make chromeos boot on the c201, and external device boot
>> and the chromebook recovery images fail after ~5 minutes, so as far
>as I
>> tell, using internal spi to flash is out of the question. I've
>resorted to
>> hardware flashing, but I can't get it (RasPi 3) talking to the chip.
>> boots into the firmware (and into recovery), so I know I haven't
>> fry it.. At least I hope.
>> I've set the pins according to multiple sources, and re-checked them
>> how many times. I've tried different configurations of powering the
>> write protect pins. I've checked continuity between the RPi and the
>> the chip too many times. The write protect screw is out. I've even
>> having it sit in the developer/recovery screens and use the power
>supplied by
>> the board. I've tried using upstream Flashrom, and I've tried using
>> Flashrom. No matter what I do, it returns "Unknown SPI chip".
>> I figured if anyone knew anything about this, it'd be you. Thanks for
>> time.
>Please consider posting this to the Libreboot mailing list as well.
>more people can help you and answer your inquiry while others can
>the question and its answers as well.
>Some notes and suggestion that may help you:
>* Make sure you've followed
>  and especially "Installing Libreboot externally, with a SPI flash
>* Check that the VDD, #WP and #HOLD of the chip are +3.3V during
>* Make sure that you're not using 1.8V logic, the chip seems to accept
>* Make sure you've disconnected the device's battery
>* Make sure you've disconnected any source of power
>* Maybe try with the battery connected, just in case
>Note that I'll be providing a recovery SPI flash image and rootfs with
>that should allow recovering from these kinds of situations. Of course,
>device is not irremediably bricked.
>Paul Kocialkowski, developer of low-level free software for embedded
>Coding blog:
>Git repositories:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]