[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUI - start?

From: Alexander Hansen
Subject: Re: GUI - start?
Date: Tue, 2 Dec 2014 10:30:02 -0800

On Dec 1, 2014, at 10:02 PM, jkr <address@hidden> wrote:


Followed your instructions below.  At one point my iMac was hung for over a half hour (even clock on screen not updating, no disk noises) and I forced it to power down.  This was apparently during fink install octave-qtmacs octave382-dev.  After rebooting, I did findk list -it octave and got:

i  fink-octave-scripts 0.3.3-1 Convenience scripts for Octave add-ons
p  liboctave382 [virtual package]
p  liboctave382-accelerate [virtual package]
p  liboctave382-accelerate-dev [virtual package]
p  liboctave382-aqua [virtual package]
p  liboctave382-aqua-dev [virtual package]
p  liboctave382-dev [virtual package]
p  liboctave382-gcc49 [virtual package]
p  liboctave382-gcc49-dev [virtual package]
i  octave382 3.8.2-4 MATLAB-like language for computations
i  octave382-dev 3.8.2-4 MATLAB-like language for computations
p  octave382-interpreter [virtual package]
p  octave382-interpreter-accelerate [virtual package]
p  octave382-interpreter-aqua [virtual package]

Then I did fink install octave-qtmac octave382-dev, counting on fink to figure out whether it had any work to do (as the list looked incomplete - no qtmac).  

That’s to be expected.  "fink list -i” lists only installed packages.

This appeared to work, apart from complaints about not being able to stat unstable/crypto/…  

There is no unstable tree, and the separate crypto tree was discontinued even before that.  This is a harmless issue in your local Fink configuration.

It said it found that it needed to install both packages, but took hardly any time.  Next it said:

Could not resolve inconsistent dependencies!

Fink isn't sure how to install the above packages safely. You may be able to
fix things by running:

 fink scanpackages
 sudo apt-get update
 sudo apt-get install octave-qtmac=3.8.2-4 octave382-qtmac=3.8.2-4

So, I ran all of the recommended commands.  During sudo apt-get install octave-qtmac-3.8.2-4 octave382-qtmac=3.8.2-4 it said:

The following packages will be REMOVED:
 octave382 octave382-dev 
The following NEW packages will be installed:
 octave-qtmac octave382-qtmac 
0 packages upgraded, 2 newly installed, 2 to remove and 0  not upgraded.
Need to get 0B/26.7MB of archives. After unpacking 791kB will be freed.

Then it appeared to proceed gracefully except for warnings like:

Removing octave382-dev ...
Removing octave382 ...
dpkg - warning: while removing octave382, directory `/sw/var/octave/3.8.2' not empty so not removed.
dpkg - warning: while removing octave382, directory `/sw/var/octave' not empty so not removed.
dpkg - warning: while removing octave382, directory `/sw/share/octave' not empty so not removed.
dpkg - warning: while removing octave382, directory `/sw/lib/octave' not empty so not removed.

Absolutely normal.

Finally it said Setting up octave-qtmac (3.8.2-4) ..., which it appeared to do successfully.

Next I ran octave --force-gui

It brought up a beautiful GUI.  Command line recall worked.  But on a first simple plot I got a dialog "octave-gui quite unexpectedly" and on the command console "octave exited with signal 11”.

Something similar has been reported for the GUI on OS X from Homebrew and Macports.  I didn’t tickle it on one of my test systems, so I thought that my build somehow missed it.  I’m setting octave-qtmac up on my production machine to see whether it is a reproducible issue or not.

I tried starting again at remove --recursive octave382.  fink said No packages to remove. I tried 'fink remove octave382' - same answer.  'find remove octave382-interpreter', same answer.  

You can’t remove octave382 because it isn’t installed.  You removed it when you installed octave382-qtmac.  

You can’t remove octave382-interpreter that way because it is a virtual package.

I tried using octave from its command line.  I generated a simple plot, but on the command console, it posted pages of:

Dec  1 17:46:56 Jamess-iMac.local octave-cli-3.8.2[1459] <Error>: CGContextFillRects: invalid context 0x0. This is a serious error. This application, or a library it uses, is using an invalid context  and is thereby contributing to an overall degradation of system stability and reliability. This notice is a courtesy: please fix this problem. It will become a fatal error in an upcoming update. 

(repeated many times).

I feel totally snake-bit.  It seems like I need to start over with a fresh installation, but it seems like I cannot. Recommendation?



Unless you change something around (removing third-party libraries, etc.) a fresh Fink installation will get you to exactly the same place, because Fink’s build system is deterministic.

Alexander Hansen, Ph.D.
Fink User Liaison

reply via email to

[Prev in Thread] Current Thread [Next in Thread]