[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GUI - start?

From: Ben Abbott
Subject: Re: GUI - start?
Date: Tue, 02 Dec 2014 14:24:32 -0500

On Dec 2, 2014, at 1:30 PM, Alexander Hansen <address@hidden> wrote:

On Dec 1, 2014, at 10:02 PM, jkr <address@hidden> wrote:

Finally it said Setting up octave-qtmac (3.8.2-4) ..., which it appeared to do successfully.

Next I ran octave --force-gui

It brought up a beautiful GUI.  Command line recall worked.  But on a first simple plot I got a dialog "octave-gui quite unexpectedly" and on the command console "octave exited with signal 11”.

Something similar has been reported for the GUI on OS X from Homebrew and Macports.  I didn’t tickle it on one of my test systems, so I thought that my build somehow missed it.  I’m setting octave-qtmac up on my production machine to see whether it is a reproducible issue or not.

The error occurs when the graphics_toolkit is set to “fltk”. The reason is that the fltk toolkit and the gui do not run in the same thread. When running the gui on MacOS X, the gnuplot toolkit is required.

close all
graphics_toolkit gnuplot
plot (rand (3))

I’ve added a bug report.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]