[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub fails to boot, prints only a single dot

From: Andrei Borzenkov
Subject: Re: grub fails to boot, prints only a single dot
Date: Tue, 9 Jun 2015 17:18:35 +0300

On Tue, Jun 9, 2015 at 5:07 PM, Alex Regan <address@hidden> wrote:
> Hi,
>>> I have a fedora20 system on a 1U rackmount Supermicro chassis with two
>>> disks
>>> in a mdadm RAID1 configuration that's been running for quite some time. I
>>> recently added two additional disks, in a separate RAID1, and mounted it
>>> on
>>> /var.
>>> After adding the two new disks, the system failed to boot. No grub boot
>>> menu
>>> or anything. Just a single dot then a newline, where the system would sit
>>> there until I eventually had to hard reset it to boot.

Do you see word GRUB printed before dot?

>>> Removing the two new disks and the system boots again normally (except
>>> for
>>> the new /var mountpoint, of course).
>>> Running grub2-install again for all four disks doesn't help. I've even
>>> uninstalled and reinstalled the kernel, and tried to manually regenerate
>>> the
>>> initramfs with no change.
>>> Does anyone understand grub enough to help troubleshoot this? I suspect
>>> it's
>>> something to do with the second-stage loader?
>> Are you sure system does not try to boot from new disks?
> I'm pretty sure I've cycled through all four disks in the BIOS boot order,
> although it's possible. It's somewhat difficult because all four disks are
> identical and the BIOS doesn't provide a way to distinguish one from the
> other.
> I've also even tried to rearrange the disks physically by rearranging the
> disk trays in the chassis...
> I've also installed grub on all four disks. Wouldn't this serve to direct
> the boot information to the disks with /boot and the real root?

Well, GRUB prints dots when it loads parts of core.img from disk.
Single dot would imply single extent which is OK. Then it jumps to it.
Now if for whatever reasons it got garbage from disk. of course
attempt to execute it will be unsuccessful.

Could you boot any live media, run
and send result to me?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]