[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: grub fails to boot, prints only a single dot

From: Alex Regan
Subject: Re: grub fails to boot, prints only a single dot
Date: Tue, 09 Jun 2015 10:07:59 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.5.0


I have a fedora20 system on a 1U rackmount Supermicro chassis with two disks
in a mdadm RAID1 configuration that's been running for quite some time. I
recently added two additional disks, in a separate RAID1, and mounted it on

After adding the two new disks, the system failed to boot. No grub boot menu
or anything. Just a single dot then a newline, where the system would sit
there until I eventually had to hard reset it to boot.

Removing the two new disks and the system boots again normally (except for
the new /var mountpoint, of course).

Running grub2-install again for all four disks doesn't help. I've even
uninstalled and reinstalled the kernel, and tried to manually regenerate the
initramfs with no change.

Does anyone understand grub enough to help troubleshoot this? I suspect it's
something to do with the second-stage loader?

Are you sure system does not try to boot from new disks?

I'm pretty sure I've cycled through all four disks in the BIOS boot order, although it's possible. It's somewhat difficult because all four disks are identical and the BIOS doesn't provide a way to distinguish one from the other.

I've also even tried to rearrange the disks physically by rearranging the disk trays in the chassis...

I've also installed grub on all four disks. Wouldn't this serve to direct the boot information to the disks with /boot and the real root?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]