[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help - SEGV_MAPERR

From: Guntupalli Santhi
Subject: Re: help - SEGV_MAPERR
Date: Mon, 13 Mar 2006 15:48:37 +0530

 In continuation of my previous mail since our application is a multti-threaded and 64 bit,
i  have used the "-mlp64  -D_REENTRANT -pthread" flags consistently at compile time and linking time. Because of this problem i am not able to proceed further.
Thanks in advance.
Thanks & Regards
- GS

On 3/13/06, Guntupalli Santhi <> wrote:
    We are porting our application from Tru64 Unix to HPUX 11.23 (IA64).
It is 64 bit application and multi-threaded. During runtime i have seen strange behaviour of our application.
I am using g++ of version 4.0.2.
when i run my application it is dumping core at
dmn_arr<desc_obj> tobj; #line no 200
where dmn_arr is a template class and it is crashing as
Program received signal SIGSEGV, Segmentation fault
  si_code: 1 - SEGV_MAPERR - Address not mapped to object.
0x9fffffffef7bce30:1 in dld_bor_text_entry + 0x81 ()
   from /usr/lib/hpux64/
As per my understanding the error SEGV_MAPERR is  it is not able to locate the template class od ( dmn_arr ).
Using gdb when i run the same application stepping each statement one by one it is working fine. if i put breakpoint directly at this statement( line 200) menetioned above  again it is dumping core as above.
What could be the problem. why i am getting this error. Any help is highly appreciated.
- GS

reply via email to

[Prev in Thread] Current Thread [Next in Thread]