[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: help - SEGV_MAPERR

From: Paul Pluzhnikov
Subject: Re: help - SEGV_MAPERR
Date: Mon, 13 Mar 2006 21:24:14 -0800
User-agent: Gnus/5.1006 (Gnus v5.10.6) XEmacs/21.4 (Jumbo Shrimp, linux)

"Guntupalli Santhi" <> writes:

> ------=_Part_15800_16678392.1142245117842
> Content-Type: text/plain; charset=ISO-8859-1
> Content-Transfer-Encoding: quoted-printable
> Content-Disposition: inline

Please don't do this when posting to usenet.

>>     We are porting our application from Tru64 Unix to HPUX 11.23 (IA64).
>> It is 64 bit application and multi-threaded. During runtime i have seen
>> strange behaviour of our application.

What's so strange about it?
You have some kind a bug (either in the application, or in the
tool chain), and your app crashes. Nothing very unusual about it.

>> when i run my application it is dumping core at
>> dmn_arr<desc_obj> tobj; #line no 200

How did you come to the conclusion that the app crashes here?
Your conclusion may well be correct, but I'd like to know what
*facts* led you to it.

>> Program received signal SIGSEGV, Segmentation fault
>>   si_code: 1 - SEGV_MAPERR - Address not mapped to object.
>> 0x9fffffffef7bce30:1 in dld_bor_text_entry + 0x81 ()
>>    from /usr/lib/hpux64/
>> As per my understanding the error SEGV_MAPERR is  it is not able to locate
>> the template class od ( dmn_arr ).

Your understanding is incorrect.
Since you successfully built your program, "it" (whatever it is)
has already located the template class just fine.

>> Using gdb when i run the same application stepping each statement one by
>> one it is working fine. if i put breakpoint directly at this statement( line
>> 200) menetioned above  again it is dumping core as above.

That usually means that the app crashes *before* that statment.
Here are some relevant gdb commands:

  run              # don't single-step, let the app crash
  info shared
  info reg
  x/20i $pc-40

>> What could be the problem. why i am getting this error.

Anything could be the problem.
Generally, IA-64 is a major main in the a** to debug, which might
explain its runaway success :)

> ------=_Part_15800_16678392.1142245117842
> Content-Type: text/html; charset=ISO-8859-1
> Content-Transfer-Encoding: quoted-printable
> Content-Disposition: inline
> <div>Hi,</div>

Please don't *ever* post HTML.

In order to understand recursion you must first understand recursion.
Remove /-nsp/ for email.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]