[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Windows 10, Melpa, TSL

From: Bo Grimes
Subject: Windows 10, Melpa, TSL
Date: Thu, 18 Aug 2016 10:39:39 -0400
User-agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:24.0) Gecko/20140623 FossaMail/24.6.0

System and Relevant Portion of .emacs

GNU Emacs 24.4.1 (i686-pc-mingw32)
Windows 10 Home, Version 1607, Build 14393.51

(require 'package) ;;
(add-to-list 'package-archives
             '("melpa" . "";))
(when (< emacs-major-version 24)
  ;; For important compatibility libraries like cl-lib
(add-to-list 'package-archives '("gnu" . "";)))
(package-initialize) ;

Problem, Possibly Solved

I'm not a programmer (by any name). Just an ordinary person cursed with a need to use software I can adapt to myself. I wish I was: "Word? Evernote? That's how you write and take notes? Perfect! Got it. Thanks." It would make my life so much more simple. I am able to make Emacs and Org-mode work more like my brain wants to work than anything I have tried since stumbling on the Internet in the computer lab during grad school (history) in the early 90s, so I persist.

Yeah, I know, stop narrating (see history above).

Yesterday, I wanted to install csv-mode because I decided to move what little spreadsheet work I do for record keeping into Emacs as well.

The Packages buffer loaded fine, but when I tried to install I got: "could not create connection to"

After some Google work, it seems I should have been using not, so I changed that, and still had the same problem.

I rarely ever install packages since all I really do is take notes, manage tasks and write, but just two weeks ago I played around with some new themes out of boredom with the one I have been using for a year, and everything worked fine.

Some more Google work led me to believe it was a TSL problem. I followed the advice here: which is basically:

Get GnuTSL, extract, copy DLLs to the bin directory of Emacs, restart Emacs. It worked.

So, what's the problem? The problem is I don't know what I did, and I don't like that. I don't know if I really fixed anything or if I created potential future problems. The only change to my system for months has been Windows updates, and everything worked fine just two weeks ago.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]