help-gnu-emacs
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs update on archlinux


From: Tom Willemse
Subject: Re: emacs update on archlinux
Date: Wed, 22 Apr 2015 15:51:05 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.0.50 (gnu/linux)

Eli Zaretskii <address@hidden> writes:

>> Date: Wed, 22 Apr 2015 07:04:41 -0400 (EDT)
>> From: Jude DaShiell <address@hidden>
>> Cc: address@hidden
>> 
>> I tried installing gnutls on my archlinux box and was told gnutls-3.40 not 
>> 3.30 was already installed and gnuemacs on archlinux was complaining about 
>> not being to find gnutls3.28.  Was an upper boundary set on gnutls version 
>> number for that particular version of emacs?
>
> AFAIR, GnuTLS 3.4 changed the ABI, so you need to install an older
> version, if the version of Emacs you installed needs that.

It sounds like Emacs needs to be recompiled. I had this problem two days
ago with my Emacs installation from git after gnutls was updated from
3.3.14 to 3.4.0 in Archlinux (with the testing repository turned on). I
don't have libgnutls.so.28 on my system, only libgnutls.so.30 (and
30.0.0 and just .so).

Perhaps the maintainer hasn't yet noticed that it's stopped working, or
perhaps they haven't had time to update it yet. The ABS[1] can be used
to rebuild Emacs until the maintainer updates it. If the maintainer
isn't aware of this issue a bug report should probably be filed on the
Archlinux bug tracker.

I hope this helps!

[1]: https://wiki.archlinux.org/index.php/Arch_Build_System



reply via email to

[Prev in Thread] Current Thread [Next in Thread]