[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: w3 from the console (and under X)

From: upro
Subject: Re: w3 from the console (and under X)
Date: Sun, 04 May 2003 10:41:14 +0200
User-agent: Gnus/5.1001 (Gnus v5.10.1) Emacs/21.3 (gnu/linux)

"Eli Zaretskii" <address@hidden> writes:

>> From: upro <address@hidden>
>> Newsgroups:
>> Date: Sat, 03 May 2003 20:27:17 +0200
>> When I run emacs under X Windows I have no problems using w3, but when
>> I run emacs from the console w3 soed not start, and I get an error
>> message in the modeline which says simply: "Wrong type argument:
>> stringp, nil". In *Messages* I can read:
>> "Set-face-attribute: Wrong type argument: stringp, nil".
> I'm not sure W3 is supposed to work on a tty, but if you have Emacs
> 21.x, please set debug-on-error to a non-nil value and then post here
> the backtrace produced when you try to start W3.  It could be that
> there's some bug, either in Emacs or in W3, that is easy to fix, since
> Emacs 21 supports faces on a tty.

Hi Eli - thanks for your answer! Here's the output from debug:

Debugger entered--Lisp error: (wrong-type-argument stringp nil)
  internal-set-lisp-face-attribute(w3-style-face-00000 :family nil 0)
  set-face-attribute(w3-style-face-00000 nil :underline nil :weight normal 
:family nil)
  font-set-face-font(w3-style-face-00000 [:family nil :weight nil :style 0 
:size nil :registry nil :encoding nil])
  w3-display-node((*document nil ((html nil ...))))
  w3-draw-tree(((*document nil (...))))
  w3-sentinel(#<buffer *Customize Browser*>)
* call-interactively(w3)

Thank You In Advance!

r-znvy: zvpunry.wryqra  jro.qr (chg gur "@" jurer vg svgf...)
ab fcnz cyrnfr

reply via email to

[Prev in Thread] Current Thread [Next in Thread]