[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: lily 1.4.3

From: Mats Bengtsson
Subject: Re: lily 1.4.3
Date: Mon, 18 Jun 2001 09:59:00 +0200

> OK, I apologize. I'm sure at least 10 of these downloads were mine, and
> although I have made an attempt at getting assistance, I can't begin to
> claim that I understand what's going on well enough to formulate a good
> bug report.

Just telling what you've done and what happens is a good way 
to get more help. I think it's better to ask for help than to 
spend hours or days of own experimentation.

What would really help in this situation is to have a script
that tests all the different programs in the installation
one by one (basic cygwin, Python, LaTex, ...).

> First off: I am trying to install lilypond on win2K (I've tried both as
> Administrator and as a user with admin privs), using the setup.exe from 
> I've tried about 15 times now, sometimes using just that setup,
> sometimes going to the cygwin page and starting from there. At the
> moment I have full downloads from both the lily setup and the cygwin
> install, and I'm doing some experimentation.

I've managed to run Lilypond using only the parts I get through
Lilypond setup, the additional cygwin parts should not be 
necessary. On the other hand, they shouldn't make any harm either.
Also, I've only tried on Windows 95, not on a NT-like system.

> I've uninstalled and deleted everything I had. I've installed only the
> lilypond setup for 1.4.3-1 and those files associated with it via the
> setup.ini from I have copied to my
> home directory, and I run ly2dvi thus:
> ly2dvi
> The result is a popup-information box, which tells me this:
> (titlebar) Python.exe - Unable to locate DLL
> (contents) The dynamic link library python15.dll could not be found in
> the specified path
> /usr/lilypond-1.4.3/wrappers:/usr/lilypond/wrappers:/usr/lilypond-1.4.3/bin:/usr/lilypond/bin:/usr/windows/Python:/miktex/bin:/usr/windows/Ghostgum/GSview:/usr/local/bin:/usr/bin:/bin:/cygdrive/c/ProgramFiles/MiKTeX/miktex/bin:/cygdrive/c/WINNT/system32:/cygdrive/c/WINNT:/cygdrive/c/WINNT/System32/Wbem
> This is a bit startling. It's repeatable (10 times!). I can't say I
> begin to understand how the files are working, but some
> things are obvious:
> python15.lib and python15_d.lib are in c:\cygwin\usr\windows\Python\libs
> (/usr/windows/python/libs) but there is no python15.dll to be found. (I
> suspect this is a bug?)

Could it be that the earlier installs of Python leaves some traces in 
the registry so the new install fails? I don't know if the Lilypond
installer uses the standard Python installation procedure for Windows
or if Jan has done his own Python package.

> I have a solution: use the cygwin install to install Python 2.1-1. I
> know (from prior experience) that this will give me enough Python that
> the dll will be there. 
> Doing this and then running ly2dvi again produces this result:
> Running LilyPond...
> GNU LilyPond 1.4.3
> Now processing: `/home/raybro/'
> Parsing...
> Interpreting music...[3]
> Preprocessing elements...
> Calculating column positions...
> paper output to `example-1.tex'...
> Interpreting music...
> MIDI output to `example-1.midi'...
> Track ...
> Analyzing example-1.tex...
> Running LaTeX...
> error: latex: command exited with value 32512
> Traceback (most recent call last):
>   File "C:\cygwin\usr\lilypond-1.4.3\bin\", line 760, in ?
>     run_latex (files, outbase, extra)
>   File "C:\cygwin\usr\lilypond-1.4.3\bin\", line 581, in
> run_latex
>     system (cmd)
>   File "C:\cygwin\usr\lilypond-1.4.3\bin\", line 313, in system
>     error (msg)
>   File "C:\cygwin\usr\lilypond-1.4.3\bin\", line 206, in error
>     raise _ ("Exiting ... ")
> Exiting ...

This looks as if LaTeX fails for some reason.

> This one befuddles me greately, because doing an ls of my home directory
> (where all this has supposedly taken palce) yeilds no sign of the .tex
> nor the .midi files that are claimed to have been created.

Yes, ly2dvi cleans up all temporary files. In my opinion, it would
be better to save all temporary files and a log of the whole run
if there's an error. Also, it's a problem that the printouts of
LaTeX are not saved.

The hacker way of debugging your problem is to run ly2dvi with 
the flag `-k', which will save all temporary files in a directory
called ly2dvi.dir. If you cd to the directory and call 
latex yourfile.latex
you will probably get some error printouts from LaTeX that
could give us a better clue on what's the problem.

> If I now run lilypond itself on the example file
> address@hidden ~$ lilypond
> GNU LilyPond 1.4.3
> Now processing: `'
> Parsing...
> Interpreting music...[3]
> Preprocessing elements...
> Calculating column positions...
> paper output to `example-1.tex'...
> Interpreting music...
> MIDI output to `example-1.midi'...
> Track ...
> address@hidden ~$ ls
>  example-1.midi  example-1.tex
> which befuddles me more. Same claims of paper and MIDI output, but this
> time the files exist. Is there something in ly2dvi that deletes these
> files after an unsuccessful run of latex? 

Yes. What happens if you run 
tex example-1.tex

> I apparently lack the expertise as yet to run latex and tex, since
> trying either gets a [la]tex.exe not found. I'm working on that.

Ah, that's the problem. MikTeX comes with its own documentation
which should provide some tips on how to verify that the installation
itself is working. Still, you might have to setup the paths to MikTeX.
There's a file /etc/profile.d/ in the cygwin environment
which tries to set the paths. You may have to edit that according to
your setup.

> Part of the reason I could download setup.exe so many times and not file
> a bug report, by the way, is that I've had different failures
> practically each time. My first install (as user raybro, rather than
> Administrator, installed 'for me') stuck me in a home dir named
> /home/500. However, everything 'seemed to work'. I could run ly2dvi -P
> and get a .ps file (and a .dvi) and the .ps would have no noteheads,
> clef or time signatures, or barlines. I sent email to the maintainer of
> the cygwin lilypond release (in france?), for this problem, and alluded
> to it when I answered the question about what I [was|intended to]
> use[ing] lilypond for, and received a reply from Mats offering help. I
> sent him the same data (the list of commands from the faq and the
> results). His response ended up in the gnu-music mailing list, as well
> (a bit of surprise to me, since I'd thought the offer was intended to
> continue as private correspondence until I at least understood enough of
> what was wrong to be able to say something public about the
> difficulties.)
> Anyway, his suggestions didn't work out, because, apparently, the
> problem was in producing pk files, and following his suggestions didn't
> cure it. 

This is one of the things that didn't work correctly in 
version 1.4.2 but has been solved in version 1.4.3.

Unfortunately, the Windows version of Lilypond is not as well
tuned as the Linux version, since all the mail developers and
most of the users run Linux. Jan has (somewhat reluctantly)
done this Windows version hoping to get a Windows user group
large enough that someone else steps up and supports the Windows
version more actively.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]