[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

freebsd 9 / clang / libobj2. Saga, Part II

From: Riccardo Mottola
Subject: freebsd 9 / clang / libobj2. Saga, Part II
Date: Tue, 24 Apr 2012 10:44:00 +0200
User-agent: Mozilla/5.0 (X11; FreeBSD i386; rv:11.0) Gecko/20120414 Firefox/11.0 SeaMonkey/2.8


not giving up freebsd9 and clang, I installed clang-devel (3.1) from ports, recionfigured and recompiled all using CC=/usr/local/bin/clang, including libobjc2.
ARC disabled.

This still do not work perfectly. Terminal doesn't appear to crash anymore (yay!). GWorkspace became more random.. It did hang this morning. When I tried again to get the output to write this email, it worked.

PRICE stacktrace:
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 2ac04300 (LWP 100099/PRICE)]
-[PRCCurves parametersChanged:] (self=0xbfbfdef0, _cmd=0xbfbfdef0,
    sender=0xbfbfdef0) at PRCCurves.m:100
100       [super parametersChanged: sender];
Current language:  auto; currently minimal
(gdb) bt
#0  -[PRCCurves parametersChanged:] (self=0xbfbfdef0, _cmd=0xbfbfdef0,
    sender=0xbfbfdef0) at PRCCurves.m:100
#1 0x08073f5a in -[PRCCurves showFilter:] (self=Variable "self" is not available.
) at PRCCurves.m:44
#2  0x2827b2ef in -[NSApplication sendAction:to:from:] (self=0xbfbfdf60,
    _cmd=0xbfbfdf60, aSelector=Variable "aSelector" is not available.
) at NSApplication.m:2232
#3 0x28326efd in -[NSMenu performActionForItemAtIndex:] (self=Error accessing memory address 0x0: Bad address.
    at NSMenu.m:1322
#4 0x2832f0ca in -[NSMenuView _trackWithEvent:startingMenuView:] (self=Variable "self" is not available.
    at NSMenuView.m:1819
#5 0x2832edc4 in -[NSMenuView _trackWithEvent:startingMenuView:] (self=Variable "self" is not available.
    at NSMenuView.m:1660
#6 0x2832f1fa in -[NSMenuView trackWithEvent:] (self=Unhandled dwarf expression opcode 0x0
) at NSMenuView.m:1851
#7 0x2832f3ac in -[NSMenuView mouseDown:] (self=dwarf2_read_address: Corrupted DWARF expression.
) at NSMenuView.m:1891
#8 0x283eeae9 in -[NSWindow sendEvent:] (self=Unhandled dwarf expression opcode 0x0
) at NSWindow.m:3729
#9 0x2827aeac in -[NSApplication sendEvent:] (self=Variable "self" is not available.
) at NSApplication.m:2109
#10 0x28279d11 in -[NSApplication run] (self=Unhandled dwarf expression opcode 0xed
) at NSApplication.m:1564
#11 0x2825db08 in NSApplicationMain (argc=-1077943200, argv=0xbfbfe460)

I tried running valgrind now on this enw setup, but I think it stopepd working alltogether:
> valgrind /Local/Applications/PRICE.app/PRICE
==2770== Memcheck, a memory error detector
==2770== Copyright (C) 2002-2010, and GNU GPL'd, by Julian Seward et al.
==2770== Using Valgrind-3.6.1 and LibVEX; rerun with -h for copyright info
==2770== Command: /Local/Applications/PRICE.app/PRICE
--2770-- Warning: DWARF2 CFI reader: unhandled DW_OP_ opcode 0x2a

valgrind: m_debuginfo/readdwarf.c:2338 (copy_convert_CfiExpr_tree): Assertion 'srcix >= 0 && srcix < VG_(sizeXA)(srcxa)' failed. ==2770== at 0x38027E87: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3802800B: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3808A4C5: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3808A883: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3808AFE6: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3808CBA9: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x380551D0: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x38050323: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3806F413: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x380814BE: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x38066071: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x38062419: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3806339D: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd) ==2770== by 0x3807D3B2: ??? (in /usr/local/lib/valgrind/memcheck-x86-freebsd)

sched status:

Thread 1: status = VgTs_Runnable
==2770==    at 0x1DFFF: ??? (in /libexec/ld-elf.so.1)
==2770==    by 0x19815: ??? (in /libexec/ld-elf.so.1)
==2770==    by 0x14E21: ??? (in /libexec/ld-elf.so.1)
==2770==    by 0x15197: ??? (in /libexec/ld-elf.so.1)
==2770==    by 0x1736E: ??? (in /libexec/ld-elf.so.1)
==2770==    by 0x114FD: ??? (in /libexec/ld-elf.so.1)

I will test now all applications and see how they do fare.
In the meanwhile I will install gcc...


reply via email to

[Prev in Thread] Current Thread [Next in Thread]