[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: More recent CVS woes...

From: Pete French
Subject: Re: More recent CVS woes...
Date: Fri, 25 Jul 2003 11:13:10 +0100

> It was an attempt to make gdnc (unless -NSHost is used) private to the 
> machine (as per the apple documentation) by using the loopback interface.

Ahhh... well, the code I originally fixed in BSD was code to do with
getting the list of interfaces. Linux assumes a fixed size for a socket
address, which is wrong under BSD (probably due to IP6 and
other protocol support I guess), where you need to use sa_len when getting
the list of interfaces.

I just tried a recompile at home with a new CVS checkout. Now I cant run
two copies of gdnc - the second one gives me:

-bash-2.05b$ 2003-07-25 11:12:05.343 gdnc[29839] gdnc - unable to register with 
name server as GDNCServer - quiting.

so that may well have fixed it. will try with an actual application when I get



reply via email to

[Prev in Thread] Current Thread [Next in Thread]