discuss-gnustep
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compileing gnustep-gui-0.8.5 problem fixed


From: Liam Whalen
Subject: Re: Compileing gnustep-gui-0.8.5 problem fixed
Date: Mon, 7 Jul 2003 02:29:10 -0400 (EDT)

I found out the problem it's been a while since I last installed GNUstep
and I guess last time I installed it I put it in /opt/GNUstep/

then I edited my /etc/profile file to run
/opt/GNUstep/System/Makefiles/GNUstep.sh

which in turn set my environemtn varialbe GNUSTEP_PATH list to
/opt/GNUstep/* etc

so whenever I ran the new shell script
/usr/GNUstep/System/Makefiles/GNUstep.sh
it would check to see if GNUSTEP_PATH list was set and sure enough it was

so whenever I tried make LD_LIBRARY_PATH=$LD_LIBRARY_PATH it would use the
old path of /opt/GNUstep/ which in turn had the old libraries in it which
caused the error below.  It took a bunch of messing around but I finnaly
rembered changing /etc/profile when I first installed GNUstep.  Anyway
alls well that ends well.

Liam


On Sun, 6 Jul 2003, Liam Whalen wrote:

> I gave up on using the new code and went back to the version's specified
> in http://documents.made-it.com/GNUstep/Build/
>
> Now I get this error when building gnustep-gui-0.8.5
>
> Making all for service example...
> ./shared_obj/ix86/linux-gnu/gnu-gnu-gnu/make_services: error while loading
> shared libraries:
> /opt/GNUstep/System/Libraries/ix86/linux-gnu/gnu-gnu-gnu/libgnustep-base.so.1:
> undefined symbol: __vacall_r
> make[2]: *** [example.service/Resources/Info-gnustep.plist] Error 1
> make[1]: *** [example.all.service.variables] Error 2
> make[1]: Leaving directory
> `/usr/local/src/gnustep-base-1.6.0/gnustep-gui-0.8.5/Tools'
> make: *** [internal-all] Error 2
>
> It looks like I've done something wrong when I compiled gnustep-base-1.6.0
> I'm not sure what that is though.
> Any ideas?
>
> Liam
>
>
>
> _______________________________________________
> Discuss-gnustep mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/discuss-gnustep
>





reply via email to

[Prev in Thread] Current Thread [Next in Thread]