[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [certi-dev] HLA_TestsSuite usage / dtest problems

From: Eric NOULARD
Subject: Re: [certi-dev] HLA_TestsSuite usage / dtest problems
Date: Thu, 26 Jun 2008 00:47:58 +0200

Le Wed, 25 Jun 2008 23:09:35 +0200,
"Gotthard,Petr" <address@hidden> a écrit :

> Eric,
> I tried the test suite, but faced some problems...
> PROBLEM #0: The CERTI's cmake doesn't detect dtest, so cmake says OK
> even if dtest is not ready. For me it would be better if CERTI's cmake
> calls dtest-autotest (or whatever else) to verify the test environment
> is OK.

That's true.
I should do that.

> So, at first I realized I'm missing dtest. ;-) After installing all
> four dtest external dependencies I have also installed dtest.
> PROBLEM #1: The dtest README.txt says it can be installed by typing
> 'python setup.py'. At least on my installation I had to type 'python
> setup.py install' (install was missing from the dtest documentation).

The dtest install should be broken, I'll check this.
If you encounter trouble with dtest you may file bug
(DTest is a TSP sub-project)

An alternate solution for using dtest 
is not to "install" dtest at all but just
tar zxvf dtest-0.5.tar.gz 
you obtain dtest-0.5/ directory

export PYTHONPATH=/path/to/dtest-0.5

I now realize that for a working dtest install
you need to setup a working ssh key-pair which
enables no-password ssh connection.

I'll write another mail on this tomorrow.

cd /path/to/HLA_TestsSuite-builddir
make test

> PROBLEM #2: When I start make test in certi I get failure for all
> tests, so I tried dtest-autotest (dtest-0.5) and got the following
> address@hidden external]# python --version
> Python 2.5.1
> address@hidden external]# dtest-autotest

> in newSequence
>     self.builder      = TAP.Builder.create(out=self.output)
> TypeError: create() got an unexpected keyword argument 'out'
> Any idea what could be wrong? I'm not a python expert, so
> unfortunatelly I will need some more help with this.

My mistake too.
DTest is using a modifyed version of Python TAP module
which is included in dtest source but not installed with
python setup.py install.

I'll fix this too.

You won't have this trouble if you use the "not install at all" method.

Thank you very much for trying, I realize my previous message was too
partial to be helpful.

I'll try a better one tomorrow.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]