[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Multi-threaded cubeful #Q0 bug

From: Jonathan Kinsey
Subject: Re: [Bug-gnubg] Multi-threaded cubeful #Q0 bug
Date: Wed, 28 Jan 2009 14:38:05 +0000

Massimiliano Maini wrote:
> address@hidden wrote on
> 28/01/2009 14:34:57:
>> Christian Anthon wrote:
>>> Jonathan Kinsey wrote:
>>>> I'm pretty sure this is a bug in the cache code that doesn't treat the
>>>> cubeful
>>>> equities correctly. I'm in the midst of changing the cache code so
>>>> can't check
>>>> in a fix at the moment. The fact that is seems to work on some
> machines is
>>>> probably a mixture of the default values being copied (0 vs rubbish)
>>>> and the
>>>> amount of cache usage (number of threads).
>>> If that is the case turning of the cache should cure the problem. I
>>> believe that you can do "set cache 0" in the command panel to turn off
>>> the cache. Could somebody who observe the problem try that, please.
>> I just tried that (I can reproduce the problem with the latest install
> but not
>> if i build the code) and it worked fine after "set cache 0".
> Ouch, scary. Definitely worth an investigation. Any idea where I should
> look at ?
> Makefiles differences maybe ? Config.h differences ?

The easiest approach is probably to just add some test code:
((cacheNode*)e)->ar[5] = ((cacheNode*)e)->ar[6] = 0;

to the start of CacheAdd() and see if that fixes the problem for people. This
code will probably change when I get around to it anyway.


Share your photos with Windows Live Photos - Free Try it Now!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]