[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Bug-gnubg] Multi-threaded cubeful #Q0 bug

From: Massimiliano Maini
Subject: Re: [Bug-gnubg] Multi-threaded cubeful #Q0 bug
Date: Wed, 28 Jan 2009 15:14:01 +0100

address@hidden wrote on 28/01/2009 14:34:57:

> Christian Anthon wrote:
> > Jonathan Kinsey wrote:
> >> I'm pretty sure this is a bug in the cache code that doesn't treat the
> >> cubeful
> >> equities correctly. I'm in the midst of changing the cache code so
> >> can't check
> >> in a fix at the moment. The fact that is seems to work on some machines is
> >> probably a mixture of the default values being copied (0 vs rubbish)
> >> and the
> >> amount of cache usage (number of threads).
> >>
> > If that is the case turning of the cache should cure the problem. I
> > believe that you can do "set cache 0" in the command panel to turn off
> > the cache. Could somebody who observe the problem try that, please.
> I just tried that (I can reproduce the problem with the latest install but not
> if i build the code) and it worked fine after "set cache 0".

Ouch, scary. Definitely worth an investigation. Any idea where I should look at ?
Makefiles differences maybe ? Config.h differences ?

Very annoying I cannot reproduce ...

reply via email to

[Prev in Thread] Current Thread [Next in Thread]