[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX] Re: What is the correct way to activate auctex and tex-mik?

From: Ralf Angeli
Subject: [AUCTeX] Re: What is the correct way to activate auctex and tex-mik?
Date: Sat, 03 Dec 2005 11:58:46 +0100
User-agent: Gnus/5.110004 (No Gnus v0.4) Emacs/22.0.50 (gnu/linux)

* Ulrike Fischer (2005-12-02) writes:

> I installed an emacs from and 
> first auctex 11.55. I activated it with 
> (require 'tex-mik)
> That worked fine.
> Yesterday I installed auctex 11.81 above the existing installation. 

How?  What commands did you use?

> emacs complained it can't find tex-mik. 
> It worked after I copied tex-mik.el from site-lisp/auctex/ to site-lisp.

Should not be necessary if the installation worked correctly.

> In the documentation I found in the section about changes, that the 
> recommanded way to activate auctex is now 
> (load 'auctex .....). 
> That worked, but didn't load tex-mik.

Yes, in AUCTeX 11.81 you have to load tex-mik.el(c) separately with
(require 'tex-mik)
/after/ the `(load "auctex.el" nil t t)' statement.

> I coundn't find a customize option 
> to change to tex-mik, so I tried to change in auctex.el tex-site to tex-
> mik: that worked but again only if I first copy tex-mik. 
> Did something go wrong during the installation? Or is it a bug that tex-mik 
> isn't found from the start? And how should I switch to tex-mik when I use 
> the (load -command? 

See above.  It would really help if you provided the commands you used
for installation.

> Adn what it the recommanded way to deinstall auctex? Uwe Siart says 
> ( one should delete some 
> folders and files and some commands in site-start.el. But I couldn't find 
> anything in site-start.el which does look like auctex command. Does auctex 
> really write something in this file?

I haven't looked at the instructions Uwe gave in this document.  Maybe
he recommends to create a site-start.el file?  The AUCTeX installation
routine does not create it itself.

With AUCTeX 11.81 you have to remove the files auctex.el, tex-site.el,
and preview-latex.el (if you installed preview-latex as well) from the
site-lisp directory of your Emacs installation (assuming this is on
Windows and AUCTeX was configured with
--prefix=<drive>:/path/to/emacs/dir) as well as the auctex directory.
You can delete the and files from the
info directory as well.

If you want to spare yourself all this hassle you can download a
precompiled CVS Emacs including AUCTeX 11.81 from
<URL:>.  There isn't needed much more
than just unpacking it a the desired place to get going.  You just
have to add
(require 'tex-mik)
to your init file.  AUCTeX's activation is already done by the


reply via email to

[Prev in Thread] Current Thread [Next in Thread]